summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 11:15:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 11:18:44 +0200
commit2d17a8bfc2a05d812544da7352a59124f40f831a (patch)
tree4a93c91496bc104ff3239661a9c0cb963c409d24 /dev-python/anyio
parentdev-python/cachelib: Remove old (diff)
downloadgentoo-2d17a8bfc2a05d812544da7352a59124f40f831a.tar.gz
gentoo-2d17a8bfc2a05d812544da7352a59124f40f831a.tar.bz2
gentoo-2d17a8bfc2a05d812544da7352a59124f40f831a.zip
dev-python/anyio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-3.5.0-r1.ebuild55
-rw-r--r--dev-python/anyio/files/anyio-3.5.0-pytest-7.patch78
3 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index f5e33716864f..b9e96550b640 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,2 +1 @@
-DIST anyio-3.5.0.tar.gz 136934 BLAKE2B 422d604c23658844467926f42c09895e54debfd3ddf2f7fa561eccae0c9cbc225f51d663cb9f98a2455736ad7a81eb4ae40a6f3ad66f3d2f0b02d0a5157203e0 SHA512 b91124c95d194eb7e4542405a973895d21562a2636d9600d528465da52536d1ffedbf5a6fc3ea5b1ff3e83e7dca2b42f090bb2ff6b077e32f5a2c314f07d3206
DIST anyio-3.6.1.tar.gz 140240 BLAKE2B 391892591bee88df8fd5c099b6670af8e01af0610f7659e2f2e717c2dfd94d6e5212260acf3acca6c8b149cab6781044fb665d579a63b322332bf87767374858 SHA512 99ae55eada2df971405a1592afd980ac964c80a4502465a2016423182409691d0c943280a3a7448efc78036e481614451585238b62ebea924709f0ba888f7604
diff --git a/dev-python/anyio/anyio-3.5.0-r1.ebuild b/dev-python/anyio/anyio-3.5.0-r1.ebuild
deleted file mode 100644
index a90f9a7309cb..000000000000
--- a/dev-python/anyio/anyio-3.5.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio/
- https://pypi.org/project/anyio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
-"
-# On amd64, let's get more test coverage by dragging in uvloop, but let's
-# not bother on other arches where uvloop may not be supported.
-BDEPEND="
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-7[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- amd64? (
- $(python_gen_cond_dep '
- >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
- ' 'python*')
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinx-autodoc-typehints
-
-PATCHES=(
- "${FILESDIR}"/${P}-pytest-7.patch
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
-}
diff --git a/dev-python/anyio/files/anyio-3.5.0-pytest-7.patch b/dev-python/anyio/files/anyio-3.5.0-pytest-7.patch
deleted file mode 100644
index 858404632959..000000000000
--- a/dev-python/anyio/files/anyio-3.5.0-pytest-7.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From fed7cc4f95e196f68251bcb9253da3b143ea8e7e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Alex=20Gr=C3=B6nholm?= <alex.gronholm@nextday.fi>
-Date: Mon, 7 Feb 2022 00:16:18 +0200
-Subject: [PATCH] Upgraded pytest to 7.0
-
----
- setup.cfg | 2 +-
- tests/test_pytest_plugin.py | 14 +++++++-------
- 2 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/tests/test_pytest_plugin.py b/tests/test_pytest_plugin.py
-index 4255702..f3b0e0c 100644
---- a/tests/test_pytest_plugin.py
-+++ b/tests/test_pytest_plugin.py
-@@ -1,5 +1,5 @@
- import pytest
--from _pytest.pytester import Testdir
-+from _pytest.pytester import Pytester
-
- from anyio import get_all_backends
-
-@@ -9,7 +9,7 @@ pytestmark = pytest.mark.filterwarnings(
- pytest_args = '-v', '-p', 'anyio', '-p', 'no:asyncio'
-
-
--def test_plugin(testdir: Testdir) -> None:
-+def test_plugin(testdir: Pytester) -> None:
- testdir.makeconftest(
- """
- import sniffio
-@@ -67,7 +67,7 @@ def test_plugin(testdir: Testdir) -> None:
- result.assert_outcomes(passed=3 * len(get_all_backends()), skipped=len(get_all_backends()))
-
-
--def test_asyncio(testdir: Testdir) -> None:
-+def test_asyncio(testdir: Pytester) -> None:
- testdir.makeconftest(
- """
- import asyncio
-@@ -140,7 +140,7 @@ def test_asyncio(testdir: Testdir) -> None:
- result.assert_outcomes(passed=2, failed=1, errors=2)
-
-
--def test_autouse_async_fixture(testdir: Testdir) -> None:
-+def test_autouse_async_fixture(testdir: Pytester) -> None:
- testdir.makeconftest(
- """
- import pytest
-@@ -177,7 +177,7 @@ def test_autouse_async_fixture(testdir: Testdir) -> None:
- result.assert_outcomes(passed=len(get_all_backends()))
-
-
--def test_cancel_scope_in_asyncgen_fixture(testdir: Testdir) -> None:
-+def test_cancel_scope_in_asyncgen_fixture(testdir: Pytester) -> None:
- testdir.makepyfile(
- """
- import pytest
-@@ -204,7 +204,7 @@ def test_cancel_scope_in_asyncgen_fixture(testdir: Testdir) -> None:
- result.assert_outcomes(passed=len(get_all_backends()))
-
-
--def test_hypothesis_module_mark(testdir: Testdir) -> None:
-+def test_hypothesis_module_mark(testdir: Pytester) -> None:
- testdir.makepyfile(
- """
- import pytest
-@@ -235,7 +235,7 @@ def test_hypothesis_module_mark(testdir: Testdir) -> None:
- result.assert_outcomes(passed=len(get_all_backends()) + 1, xfailed=len(get_all_backends()))
-
-
--def test_hypothesis_function_mark(testdir: Testdir) -> None:
-+def test_hypothesis_function_mark(testdir: Pytester) -> None:
- testdir.makepyfile(
- """
- import pytest
---
-2.35.1
-