summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:14:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:14:32 +0200
commit914f18a309185dfeb450678d80b4972a93c80eee (patch)
treeefa97708c140e13dafb8c3a5ca5d16bf1af6923c /dev-python/apispec/apispec-4.4.2.ebuild
parentdev-python/identify: Bump to 2.2.6 (diff)
downloadgentoo-914f18a309185dfeb450678d80b4972a93c80eee.tar.gz
gentoo-914f18a309185dfeb450678d80b4972a93c80eee.tar.bz2
gentoo-914f18a309185dfeb450678d80b4972a93c80eee.zip
dev-python/apispec: Bump to 4.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec/apispec-4.4.2.ebuild')
-rw-r--r--dev-python/apispec/apispec-4.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/apispec/apispec-4.4.2.ebuild b/dev-python/apispec/apispec-4.4.2.ebuild
new file mode 100644
index 000000000000..411599826ebf
--- /dev/null
+++ b/dev-python/apispec/apispec-4.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}