summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-07 07:53:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-07 08:33:29 +0200
commit91c02ab476e672ab64a311d242d7bd0fced1337a (patch)
treec2f3e60525441cb49748d449f00c8e8132772d5b /dev-python/apispec
parentdev-python/pillow: Bump to 8.3.1 (diff)
downloadgentoo-91c02ab476e672ab64a311d242d7bd0fced1337a.tar.gz
gentoo-91c02ab476e672ab64a311d242d7bd0fced1337a.tar.bz2
gentoo-91c02ab476e672ab64a311d242d7bd0fced1337a.zip
dev-python/apispec: Bump to 4.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-4.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 0de235be6db8..8a2889b1880d 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -3,3 +3,4 @@ DIST apispec-4.4.2.tar.gz 64660 BLAKE2B 1e53d4b3f8856e76565690773085dfcbaaab4e17
DIST apispec-4.5.0.tar.gz 65423 BLAKE2B ce6cc6f466d274db6aa5f8b27c3a9340daff7934b9293c501b5305b4a6ccbd22e8b12a163e20e5e02d571a8177adb6d5b3196ffa46ae68f2931b6c3ced2b4d0c SHA512 0abb186182513a6d7e4aeeeb80cd8976eebe7c40932ca7c53cd8be149e65a768235436382bab2006a79bcdf345cde55fd69eb3f28f8d14cde5fe064f7c7a76ad
DIST apispec-4.6.0.tar.gz 66147 BLAKE2B 98127cb2bf938cc1928e13e1169804eea174351a0f4eeaabc801da711d0861bc35a9761e9f1bc478a44d6a85989a1aba1840b3e472599064240a880fda8e45b4 SHA512 b030e5400a9abce06576406f83befb298814617e06729f29c2ee70517cf456901b67e60880b3b4baec096717a91341e8268bcd8e01fd566b7c6e03709afd7c3b
DIST apispec-4.7.0.tar.gz 66274 BLAKE2B dbb14dd831eddeb9f086643b6182ccc3e529e22ad7e31d1d4dd2dce54edf76c6cf01a74438383df5ccec18cf863334d5cdbd45214791c01632d7f7efa63f7aa3 SHA512 53c0a1e6db81439a7c3f8e933cac28003dd84444e65986a29aef8a6ec761999c84417902448288d69c5873d12dded2156e79bedc5bd4bd0fd472ea014e65a6c7
+DIST apispec-4.7.1.tar.gz 66356 BLAKE2B f78ab7f10c7a10f3d62b4d02e5a33cc1972aea0b33af1c485a11c2c415b2913a4d8151a9aa44de9876fa1ec6ebe02d448fb50dcc573e6a4779265ee07bda0329 SHA512 e5ead9a867d9dd18f2fb7509b6ef4afd9ec04cc102f55684a66e8f5ebe1b8e3e4129c62b7fd50f0a337547336375cee612e1bec620fa957f8f90d11968538c8e
diff --git a/dev-python/apispec/apispec-4.7.1.ebuild b/dev-python/apispec/apispec-4.7.1.ebuild
new file mode 100644
index 000000000000..33a1c08135a1
--- /dev/null
+++ b/dev-python/apispec/apispec-4.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}