summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-11 07:03:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-11 07:55:54 +0100
commitbc7477cd5e7126882008f7c0208b12ef8344e70c (patch)
treeb9a3c961d573af58bb41efd0e14c5b19949cac42 /dev-python/apispec
parentdev-python/platformdirs: Bump to 3.1.1 (diff)
downloadgentoo-bc7477cd5e7126882008f7c0208b12ef8344e70c.tar.gz
gentoo-bc7477cd5e7126882008f7c0208b12ef8344e70c.tar.bz2
gentoo-bc7477cd5e7126882008f7c0208b12ef8344e70c.zip
dev-python/apispec: Bump to 6.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 65cde9e42167..0bf333a031cc 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,4 @@
DIST apispec-6.0.2.gh.tar.gz 72472 BLAKE2B 0ff39ad92648cd63487f8901dc918fc1c642ce677ef73d5a7c849cdafbf7c81ac3ec51224575cd83c060930c1b2ef0ebfb3e94e1fb30f040e4dc4aa2bd221936 SHA512 aa5e2cc41d5b3c4555da929819135df30192e6f6ff08518d62674495f0d28c14e51a0aa111b289e5f9d7205f821c1fd4e28b914899ea3e15b3e20f6052258117
DIST apispec-6.1.0.gh.tar.gz 72570 BLAKE2B 524573d188c487c57bed25f735888623d3abb848a949920bfa7ef8737b33d5fa29670d90af47eedb8b6202ddd553d04c2809285151555159c81203989fe23a2c SHA512 95d24491992572304b5c5adbb2a50668d55cb60585e32c85f718f2c211eb15c35082146fd6c88b7d3d574b4fef8f49fdd3cfe714f15d80aa657f3b48f38a40ed
DIST apispec-6.2.0.gh.tar.gz 72921 BLAKE2B 32a0f5c607277afb4db319183777e9cdba625f17942a983ccf8b67fead459783b4d88e8bbd71c24be421aa068fb6dd96c193806b287de3d63f3456ec840132d7 SHA512 432391b42dab9cb1172bd6959346dabf639dabec85540cd6f3c0f227cbc833a8424ae6b34e3d4d79f6bf41d3cf24464d1f5584204e143c3dc2d092029a2d2cf7
+DIST apispec-6.3.0.gh.tar.gz 72981 BLAKE2B a26bad851c01665157c6cb494896d43c97c41abb989887dd0b7041c0545ea5ab1c84ed54d676e53d2ec7ce0bf171c9adb563a154beda1de55a6be9e8d042ae15 SHA512 995bd522d59bd04a61a53e2ca0976b52171242048b6e49cf8ed19543a785a3b70338c6b2be67cc785ed9948e0cf84d78cd814a16ce422e2ac0711ffeb267bd24
diff --git a/dev-python/apispec/apispec-6.3.0.ebuild b/dev-python/apispec/apispec-6.3.0.ebuild
new file mode 100644
index 000000000000..a4536d135d69
--- /dev/null
+++ b/dev-python/apispec/apispec-6.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}