summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/appdirs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/appdirs')
-rw-r--r--dev-python/appdirs/Manifest2
-rw-r--r--dev-python/appdirs/appdirs-1.2.0-r1.ebuild31
-rw-r--r--dev-python/appdirs/appdirs-1.4.0.ebuild31
-rw-r--r--dev-python/appdirs/metadata.xml17
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/appdirs/Manifest b/dev-python/appdirs/Manifest
new file mode 100644
index 000000000000..0c9e7933dad4
--- /dev/null
+++ b/dev-python/appdirs/Manifest
@@ -0,0 +1,2 @@
+DIST appdirs-1.2.0.zip 22478 SHA256 266036a5f1eb785a5eff2a362f552b7943dc7d83737a6a201f21276bd9ef234d SHA512 26605262f01f6f4cd508155b8199a88645d8203700b87660bdf6f3bfa409b04136df101a5ca3ddbcf7f97a30bea2fc5ce34e197e8be21f6a20b1257b44440093 WHIRLPOOL 60ab7b58dfd63d161d8d30ca411cb8f4d654f2a56bb7b0078ee85f0f315abbb13035e0609c7f87d5f8cce44234fa714ad461edad3f0817adaa8388a73ba91411
+DIST appdirs-1.4.0.tar.gz 14358 SHA256 8fc245efb4387a4e3e0ac8ebcc704582df7d72ff6a42a53f5600bbb18fdaadc5 SHA512 a16fbad419e593acf1b58a3f8f893d206b3fc1a269757213a34d129e6fc39aa041efacb7964d326b82376373315357c93e85b272f374a096d9a63e73e3ce1dac WHIRLPOOL 0e12bf1875e489fbfb2ed48b125917bb6e176b90051a0afe2b64f431bbd1f5be499b7c0631302513387c440a05b2eb067fefaf54141424c260834cba854b7e6f
diff --git a/dev-python/appdirs/appdirs-1.2.0-r1.ebuild b/dev-python/appdirs/appdirs-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..04d22ddda98c
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.2.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="http://github.com/ActiveState/appdirs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# api.doctests is missing in the dist zipfile
+# and the 'internal' doctest does nothing
+RESTRICT=test
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/appdirs/appdirs-1.4.0.ebuild b/dev-python/appdirs/appdirs-1.4.0.ebuild
new file mode 100644
index 000000000000..2ca055f8c360
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="http://github.com/ActiveState/appdirs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# api.doctests is missing in the dist zipfile
+# and the 'internal' doctest does nothing
+RESTRICT=test
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/appdirs/metadata.xml b/dev-python/appdirs/metadata.xml
new file mode 100644
index 000000000000..ffe48945f004
--- /dev/null
+++ b/dev-python/appdirs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ A small Python module for determining appropriate platform-specific
+ dirs, e.g. a "user data dir".
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">appdirs</remote-id>
+ <remote-id type="github">ActiveState/appdirs</remote-id>
+ </upstream>
+</pkgmetadata>