summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-01-25 02:20:15 -0500
committerTim Harder <radhermit@gentoo.org>2017-01-25 02:23:20 -0500
commit89cd543cc1143287106cb4ab907cd5a5b90a78ed (patch)
treeb29facae82d52db90fd4f8d89733508eafc25b11 /dev-python/appdirs
parentdev-ruby/archive-tar-minitar: add ruby24 (diff)
downloadgentoo-89cd543cc1143287106cb4ab907cd5a5b90a78ed.tar.gz
gentoo-89cd543cc1143287106cb4ab907cd5a5b90a78ed.tar.bz2
gentoo-89cd543cc1143287106cb4ab907cd5a5b90a78ed.zip
dev-python/appdirs: force usage of distutils instead of setuptools
In order to break a cyclic dependency with setuptools since appdirs is required by setuptools and isn't vendored anymore.
Diffstat (limited to 'dev-python/appdirs')
-rw-r--r--dev-python/appdirs/appdirs-1.4.0-r1.ebuild30
-rw-r--r--dev-python/appdirs/files/appdirs-1.4.0-distutils.patch22
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/appdirs/appdirs-1.4.0-r1.ebuild b/dev-python/appdirs/appdirs-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..fc2827a2030a
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="https://github.com/ActiveState/appdirs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# api.doctests is missing in the dist zipfile
+# and the 'internal' doctest does nothing
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}"/${P}-distutils.patch )
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch b/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch
new file mode 100644
index 000000000000..eb0cf8217545
--- /dev/null
+++ b/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch
@@ -0,0 +1,22 @@
+Force setup.py to use distutils in order to break setuptools cyclic dependency.
+
+--- appdirs-1.4.0/setup.py
++++ appdirs-1.4.0/setup.py
+@@ -2,7 +2,7 @@
+ import sys
+ import os
+ import os.path
+-from setuptools import setup
++from distutils.core import setup
+ import appdirs
+
+ tests_require = []
+@@ -38,8 +38,6 @@
+ Programming Language :: Python :: 3.2
+ Topic :: Software Development :: Libraries :: Python Modules
+ """.split('\n') if c.strip()],
+- test_suite='test.test_api',
+- tests_require=tests_require,
+ keywords='application directory log cache user',
+ author='Trent Mick',
+ author_email='trentm@gmail.com',