summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 15:19:30 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 15:26:09 -0400
commit657215cab9b0fafe965d73b3ffa3b437a891de2d (patch)
tree9363195de69abd9ad3f2552d23c439c2a7b579d0 /dev-python/apsw
parentdev-python/yarl: version bump to 1.2.6 (diff)
downloadgentoo-657215cab9b0fafe965d73b3ffa3b437a891de2d.tar.gz
gentoo-657215cab9b0fafe965d73b3ffa3b437a891de2d.tar.bz2
gentoo-657215cab9b0fafe965d73b3ffa3b437a891de2d.zip
dev-python/apsw: version bump to 3.23.1_p1
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.23.1_p1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index aeb626f47899..69ef89a05740 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,4 @@
DIST apsw-3.19.3_p1.zip 678966 BLAKE2B 1726a50024369831fe0ee442676adc4415c7b71e5e12beddd4e09f688aad930bb54664435c569ca728c2dd7b24b4eb46655778c7c35249731f3a83194a40fe6b SHA512 9f9e05c865a19e7b6e6b37e6228027c027ba683be2d5ff7a1767bb3bbeb090bf66879a0eead4fc9e34fc4d84c1edc98137b2839f84ffab9bd36330d05435ab4e
DIST apsw-3.21.0_p1.zip 680827 BLAKE2B 8fceb2d782f3bbaba28f26904ed11281be7e2be351d78c41d39d2941ad45304bd7e62cfbbc9134e21b1ffad4f7b7d1373a2866d6cbb61345c263502b23fb018a SHA512 c2009d243765532e27220478d1164f97201afbd2b1de1e4090b4f35b63c83d0a82d2bdfe14c6625858867633995d3d8eef91f17ecbbd915f99e5a4a4edfa7b61
DIST apsw-3.22.0_p1.zip 680988 BLAKE2B eda9b217ee8d23b5fc80e5d240b11493f8ef82208f3b694619ba168f4bd640691cdf253d9315fb0f2d178fcce2bd1ed4028d75488f5fb3c0db95c518fec8f71d SHA512 c82de649a9245283dd0acc37700270c6c4dde1995cdc88bf7afb7cb3913a6f1a4a7a077e80eeb70cccf2fcb058406b610c9f05f478c6dc9ee8f7ff9cde7c7395
+DIST apsw-3.23.1_p1.zip 682088 BLAKE2B 0b1c492c68522f9d3d1c693370b3b1562de0e4521f3a3de0988c40ddcf717f79201555228c16b9b9870db47582bf2b774f7e9ce0ddea4e19c3d132bbf2322551 SHA512 8f3bc9e619ed8671a0804e6d3c9ecf34d452a4e6fe540fb23bfb6ae67578971013300ad6cdffe3be2fc1197c4fd3af096802aef5994cbe53253467133363ac62
diff --git a/dev-python/apsw/apsw-3.23.1_p1.ebuild b/dev-python/apsw/apsw-3.23.1_p1.ebuild
new file mode 100644
index 000000000000..2f4ee216ac74
--- /dev/null
+++ b/dev-python/apsw/apsw-3.23.1_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}