summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:16:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:42:58 +0200
commit52022a5222101960c3d64cd02422affac0746843 (patch)
tree909fd1d9700f5f5f3efd4a0b2503d4052c0d826c /dev-python/argh
parentdev-python/apsw: Bump to 3.43.2.0 (diff)
downloadgentoo-52022a5222101960c3d64cd02422affac0746843.tar.gz
gentoo-52022a5222101960c3d64cd02422affac0746843.tar.bz2
gentoo-52022a5222101960c3d64cd02422affac0746843.zip
dev-python/argh: Bump to 0.30.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.30.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index c21797e60428..2780e70dd451 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,3 +1,4 @@
DIST argh-0.29.4.tar.gz 52694 BLAKE2B 6d2b75200ea7b570ac199139ba7bc92b5bfa41fa4e21d19eff17d8506c4a28c6043413a25679cab52f9d81b8bb9a1f35b77ffee3beaa98c43660ad9e5c6b8dfc SHA512 017346afb237429de1228f604a763f919528fd359edfabb7b5a5c3a48c5e5be5a5a385672d54299cd15e5bc82257d8c33816fbc463873ffb9b3c3a54b40fccfc
DIST argh-0.30.0.tar.gz 59803 BLAKE2B 2e0a5d9dfbe5177ac434224b78b0575f4b2b4373abee8ba97cbb31617e855309ed152e83e84c03c3b5666705493011bc4a0c86396ed5891914e9af3436d9b058 SHA512 a16fa32cd1fdcd842335ebecdaefce48d248a0a6449b592a3e83dbeb02543123e36dc057f457d7bb097c1b4e118d11a800ecc40a3847e81533d8dcf1d292111d
DIST argh-0.30.1.tar.gz 60275 BLAKE2B 24e80f51f2c2f76d605b4282045ffe98f274f3e4692a3dfc26e35aa32a97a79fdc78b795622a2cb593ed83657c1cb1ecef562b43f5b8dc3097f4909403aa98ce SHA512 a24bdc92180ebce217433842e223e958ef222dc81feba8ee22ba0b219b5c259f3d2e79f8ebdf7334b624f69c83814322aa1e768cc72f644c0b16fb2863910035
+DIST argh-0.30.2.tar.gz 61528 BLAKE2B f4ef544c67cecaeaba63ca7c97425be0924712c380081971cbe67fbcfeb4a723b5a3e9bca4c33db02fb6466a4a632d756282f8e49a2c69dad4589004c3f83acc SHA512 68950e521fb6c98dbef8c1df334c2a0ae8253f6874a64d8b891c94608ac959344bae0ba65d61379796f304197f5b7f55ab8444957d1b230aa2e4d19bb080953e
diff --git a/dev-python/argh/argh-0.30.2.ebuild b/dev-python/argh/argh-0.30.2.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.30.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest