summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-09 06:23:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-09 06:23:35 +0100
commit6e7b4ea00ee2a7819238ae1cdfa0469bb4a364f1 (patch)
tree1fa9a720edff0aa552ffe340a3362bbbe0f208e0 /dev-python/argh
parentdev-python/aiofiles: Bump to 23.1.0 (diff)
downloadgentoo-6e7b4ea00ee2a7819238ae1cdfa0469bb4a364f1.tar.gz
gentoo-6e7b4ea00ee2a7819238ae1cdfa0469bb4a364f1.tar.bz2
gentoo-6e7b4ea00ee2a7819238ae1cdfa0469bb4a364f1.zip
dev-python/argh: Bump to 0.27.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.27.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 11aa6388aa91..4ed4fb355d9f 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1 +1,2 @@
DIST argh-0.26.2.tar.gz 32913 BLAKE2B 315dc36c4a98cb4a8fdab68a30ed3d4d87d1565717722ed496255d8b1b4e505277032217da4c5d750f210974890d8094c52f920044173ff2168adf7cb7f6a2bd SHA512 90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707
+DIST argh-0.27.1.tar.gz 49106 BLAKE2B 48f21d920d97111656cb5b18c956c7fdda94ae242f92ebfb02c47b55d5ccc1b82b0ef8b94a721f97fb3638b15b38ce3293fbe46ab123ed9c968efdb2e881d8f3 SHA512 edddd35b2a90c6286818986945e9ea8484dd06bc263016d8c52b0e29475dbad610d673acc0918d0cf62657b1d965bb0d59e51af4c384ae0610f471c748a90999
diff --git a/dev-python/argh/argh-0.27.1.ebuild b/dev-python/argh/argh-0.27.1.ebuild
new file mode 100644
index 000000000000..5a8b81d933a6
--- /dev/null
+++ b/dev-python/argh/argh-0.27.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest