summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-26 18:37:22 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-26 18:40:05 -0700
commit72cf78766ca89a0dc71b7401dcdd7c62097743c8 (patch)
treea6f1c655ed67188f5b1bc0a75f57f7bb842d0d39 /dev-python/arpeggio
parentnet-libs/libtorrent-rasterbar: add back py3.6 support (diff)
downloadgentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.tar.gz
gentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.tar.bz2
gentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.zip
dev-python/arpeggio: Bump to version 1.9.2
Reported-by: Alex Barker <alex@1stleg.com> Closes: https://bugs.gentoo.org/719478 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/arpeggio')
-rw-r--r--dev-python/arpeggio/Manifest1
-rw-r--r--dev-python/arpeggio/arpeggio-1.9.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/arpeggio/Manifest b/dev-python/arpeggio/Manifest
index 69fbf00d8083..372a843d0803 100644
--- a/dev-python/arpeggio/Manifest
+++ b/dev-python/arpeggio/Manifest
@@ -1 +1,2 @@
DIST arpeggio-1.9.0.tar.gz 757412 BLAKE2B f89850a16b2ac1a87cbac3ae0f10d4c04af6097bfb9292abec24c8b938bdf3b837c4d292650b2e335ee5b4b03cd149e1722e35ceabf1b59fd4577ba7e62a8e44 SHA512 179ec76813476823f316471e1b313f377064a75879c52060e547fd755ae72947594dc4d6e58a798150620e82c8b123fbd88484881c12ccb311c47bc93a45a0cd
+DIST arpeggio-1.9.2.tar.gz 761920 BLAKE2B ba8c8a5cb8965325c1c3be68a481e024b0ab703d5f60fd9ccb2589fe5efe2618fd24f2b9bc36823005897c83e233bc97372a0e3d2010cf2e2399b96aec58feb5 SHA512 fa1057caaa0b5d26937c6e5aed719f64b293d3332e3ce0277a586bd48ca136792a4811c292fd87f2e58148874e008a6f2f621630052c5dfaf0e0efe2e8039353
diff --git a/dev-python/arpeggio/arpeggio-1.9.2.ebuild b/dev-python/arpeggio/arpeggio-1.9.2.ebuild
new file mode 100644
index 000000000000..5623c7389bdf
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+MY_PN=Arpeggio
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/igordejanovic/Arpeggio"
+SRC_URI="https://github.com/igordejanovic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e 's:packages=find_packages(:\0exclude=["examples", "examples.*"]:' -i setup.py || die
+}
+
+python_test() {
+ pytest -vv || die "Testing failed"
+}