summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-01 18:25:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-01 18:40:30 +0100
commit7fa892f78e548fd4230d1787f07b47b3fdc50a64 (patch)
tree71ed4796c9bc52a63a79f5bb6a7805f20897ce59 /dev-python/arpeggio
parentwww-servers/tomcat: removed vulnerable 8.5.57-r1 (diff)
downloadgentoo-7fa892f78e548fd4230d1787f07b47b3fdc50a64.tar.gz
gentoo-7fa892f78e548fd4230d1787f07b47b3fdc50a64.tar.bz2
gentoo-7fa892f78e548fd4230d1787f07b47b3fdc50a64.zip
dev-python/arpeggio: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/arpeggio')
-rw-r--r--dev-python/arpeggio/Manifest1
-rw-r--r--dev-python/arpeggio/arpeggio-1.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/arpeggio/Manifest b/dev-python/arpeggio/Manifest
index a56b413d596f..707e6994db08 100644
--- a/dev-python/arpeggio/Manifest
+++ b/dev-python/arpeggio/Manifest
@@ -1 +1,2 @@
+DIST Arpeggio-1.10.0.tar.gz 766416 BLAKE2B 75898c5be536998a12ec0efb8ca0729913e9ac7ac8481f614cb1bfd5332015bd2c22722cc6836511e1b77d933fe497538db1a00804e2cbf409af7cc153ba15c6 SHA512 368c478114ddedbf40c94b4e656945063df5661deacc9c75780ddca18198a9e3e504718fc6c9a1e84c11c5c8f2b454584d1cfc5a14ea2b783e97b8e317047023
DIST arpeggio-1.9.2.tar.gz 761920 BLAKE2B ba8c8a5cb8965325c1c3be68a481e024b0ab703d5f60fd9ccb2589fe5efe2618fd24f2b9bc36823005897c83e233bc97372a0e3d2010cf2e2399b96aec58feb5 SHA512 fa1057caaa0b5d26937c6e5aed719f64b293d3332e3ce0277a586bd48ca136792a4811c292fd87f2e58148874e008a6f2f621630052c5dfaf0e0efe2e8039353
diff --git a/dev-python/arpeggio/arpeggio-1.10.0.ebuild b/dev-python/arpeggio/arpeggio-1.10.0.ebuild
new file mode 100644
index 000000000000..13f0348512f8
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/^setup_requires/,/^[^[:space:]]/d' \
+ -e '/^exclude/a\
+ examples.*' \
+ -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}