summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-16 08:41:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-16 10:18:45 +0200
commit0db6ed79545f180657e76d0d0074245bafee8c61 (patch)
tree3a014e4dea1e5054cba59599394c2a78771587ac /dev-python/asgiref
parentnet-misc/youtube-dl: Version 2020.06.16.1 (diff)
downloadgentoo-0db6ed79545f180657e76d0d0074245bafee8c61.tar.gz
gentoo-0db6ed79545f180657e76d0d0074245bafee8c61.tar.bz2
gentoo-0db6ed79545f180657e76d0d0074245bafee8c61.zip
dev-python/asgiref: Bump to 3.2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.2.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index c595938870cd..17e5062d9af4 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.2.7.tar.gz 25350 BLAKE2B a92d573330b1d10ba9c8d963c0824bce93151f0e38533f81a292ec0b98bc218e3b214e44ed1dadcaf10b94e94fd626cea00a5da40c5dc129b7f40ca2c5afa432 SHA512 a7b8b94e14299ced539c7ca60d310bbbde2af0f40bfa404d176a95bb6cd37402bf6bef5a5a309cdcdda4852908717a83763d7deb520b05ce74977a3bca4621e9
+DIST asgiref-3.2.8.tar.gz 25469 BLAKE2B c6c3510159aa3a5a35f5d16b427d074b72973576cc4747076caf43854567c628eb37703bb5916cfda9d9dac45c700f881957cbc6a991ab13731c54ef2f6aca53 SHA512 895a0ff28a7d11facc0a41ae603099afb49c2e01ff2d912655d27fff2e2aa0ee8d84fcba45fe873260b39de0e3dd225ca5218100d4bb96c83e63d1fe36f4683a
diff --git a/dev-python/asgiref/asgiref-3.2.8.ebuild b/dev-python/asgiref/asgiref-3.2.8.ebuild
new file mode 100644
index 000000000000..520ccd29acf5
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.2.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest