summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-18 23:59:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-19 01:40:32 +0100
commit3bf5f628129d0d08cee773c73a818668217702a6 (patch)
tree274f28624064fda47383e0e0ad5b82912079abb9 /dev-python/asgiref
parentdev-python/hypothesis: Bump to 5.41.3 (diff)
downloadgentoo-3bf5f628129d0d08cee773c73a818668217702a6.tar.gz
gentoo-3bf5f628129d0d08cee773c73a818668217702a6.tar.bz2
gentoo-3bf5f628129d0d08cee773c73a818668217702a6.zip
dev-python/asgiref: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.3.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index 1275dc91eb5c..76cce639fab0 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.3.0.tar.gz 26945 BLAKE2B bdb1154175f95fc068fd1841a69ec9c5e782c212d9649aef0b9ca7592987f88d23311149f573febd76e5ab6fea4e6087a8c5e6e9e2edb4dab37d34ff3d180845 SHA512 fbb66af8f0e2bbeed31ae6ac358f045c0eef6cdeec6edbaf358f7551ff24e69233cfbc898b60ac9d16d747a9fb7e10a8b203065602140c025b2ae7d4d7229def
+DIST asgiref-3.3.1.tar.gz 27197 BLAKE2B 1a883ed8b87dd1214ffb7672796159684f04a9a38d75562df38455ea039667f877020263b4577a3f6f7cfdfa0aae2a2074781db669f10c5b639a5009ee4c94b3 SHA512 2d709e8b0ea8b9f11f485ee438cfbbfe8a832de1aa37094a6339cfff23c2605ec79f691320c42bebf46f3bddb005ebb6857d17a8ad641c87a149536cc65984e6
diff --git a/dev-python/asgiref/asgiref-3.3.1.ebuild b/dev-python/asgiref/asgiref-3.3.1.ebuild
new file mode 100644
index 000000000000..2a8bf860303e
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest