summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:47:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:33 +0200
commit9076675888dba8b6f61ce52762a586ff85b49fde (patch)
tree2a700b84906efaecc27efc040ebf0fef51042c0a /dev-python/asgiref
parentdev-python/autoprop: Bump to 2.2.0 (diff)
downloadgentoo-9076675888dba8b6f61ce52762a586ff85b49fde.tar.gz
gentoo-9076675888dba8b6f61ce52762a586ff85b49fde.tar.bz2
gentoo-9076675888dba8b6f61ce52762a586ff85b49fde.zip
dev-python/asgiref: Bump to 3.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.3.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index b4d6dbca0146..d1df77f47c8b 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.3.1.tar.gz 27197 BLAKE2B 1a883ed8b87dd1214ffb7672796159684f04a9a38d75562df38455ea039667f877020263b4577a3f6f7cfdfa0aae2a2074781db669f10c5b639a5009ee4c94b3 SHA512 2d709e8b0ea8b9f11f485ee438cfbbfe8a832de1aa37094a6339cfff23c2605ec79f691320c42bebf46f3bddb005ebb6857d17a8ad641c87a149536cc65984e6
+DIST asgiref-3.3.2.tar.gz 30088 BLAKE2B 7c2b6083a0e0bd19162d4e1e12ad8e3b7267e8e004494eeca0e22ce13acd3bdc7b4ab056f72bb19209b7f933cee817e50930e31be798a89d0952d9de38fc6d67 SHA512 e2259add28554968936e09bf6a53cf71cef4e2e01d58d8e9651543657ba8517be5f2dd7d76334394cac579f7d560e3ab1c498434bbd67276b336ddd78644ba1f
diff --git a/dev-python/asgiref/asgiref-3.3.2.ebuild b/dev-python/asgiref/asgiref-3.3.2.ebuild
new file mode 100644
index 000000000000..c10fad78bb37
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest