summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-06 21:34:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-06 21:40:57 +0200
commitd1e819b30e3fc20bfcde3750580be6aff2e0691f (patch)
tree45adf3b6b9b992a72c8d88ea554606effd661859 /dev-python/astor/astor-0.8.1-r1.ebuild
parentdev-python/astor: Enable pypy3 (diff)
downloadgentoo-d1e819b30e3fc20bfcde3750580be6aff2e0691f.tar.gz
gentoo-d1e819b30e3fc20bfcde3750580be6aff2e0691f.tar.bz2
gentoo-d1e819b30e3fc20bfcde3750580be6aff2e0691f.zip
dev-python/astor: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astor/astor-0.8.1-r1.ebuild')
-rw-r--r--dev-python/astor/astor-0.8.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/astor/astor-0.8.1-r1.ebuild b/dev-python/astor/astor-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..a73a5388bc50
--- /dev/null
+++ b/dev-python/astor/astor-0.8.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://pypi.org/project/astor/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_rtrip.py
+)