summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/astor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/astor')
-rw-r--r--dev-python/astor/Manifest4
-rw-r--r--dev-python/astor/astor-0.3.ebuild19
-rw-r--r--dev-python/astor/astor-0.4.1.ebuild29
-rw-r--r--dev-python/astor/astor-0.4.ebuild29
-rw-r--r--dev-python/astor/astor-0.5.ebuild29
-rw-r--r--dev-python/astor/metadata.xml8
6 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/astor/Manifest b/dev-python/astor/Manifest
new file mode 100644
index 000000000000..25304715ddd4
--- /dev/null
+++ b/dev-python/astor/Manifest
@@ -0,0 +1,4 @@
+DIST astor-0.3.tar.gz 10193 SHA256 64d30fceccc46fe0c9d8afd1d60f5c9c1f7f2c2504a10ccc1548ac34fc3a8ce9 SHA512 ee75eeb795c87c1b86872af1ef8cd573b857fe973b4c6dea2a1484b37203bab3fcaa75f2d29eb499c6c109caed068b25156dfbb19934856cc4980f4f0f36a4fc WHIRLPOOL e20fda731853578ec8c13cdfdab04569a0435036f2e9242e1cc0d8b92425a2ccf06ec7c5f8014323136059da8cdb59de98b9dcb1fd633890ff6dcc8508356708
+DIST astor-0.4.1.tar.gz 10865 SHA256 df38bb923b9111b873f1b812f5f4932110ead7c7dd8b4734d9eb7968c074d9b0 SHA512 9c1b5e2d17112ffe8e7f8ed75acc3e0c488f0d2b4c32452e6a89aea43c090be984f1bbf3e31c44b09ad6c63e0a2ccb837bd1b730fab7114a9eae66899fdd314f WHIRLPOOL 544860e33f643e15400f626779977cce852be7d39e67333af140483cad640556be9a748a345afb4219fbc306deb55e88bc49b119498caffa0b6b261639ced800
+DIST astor-0.4.tar.gz 11188 SHA256 26ddb1ae3c372a09702709e91544eece9e8c885fdae7b2553838d440492fc24c SHA512 8a36668cb359795652eee61998281d4dadab875a6ad2e4c351385ae67a21352a3a45de5233c4dc31a9060e01d4525acd9a8d233ef7f322fbdc925e9aa85346c7 WHIRLPOOL 4841e01310245b21559947c2eac677a45498edae94ad97009704929f5345f31814b82d086b996ca54cc2b04df7026921eabfa5e95131ef410192043a0114cf83
+DIST astor-0.5.tar.gz 10999 SHA256 4abff251d3f03cbe99106cc16e0dc94adc4f88d580c34a717741c7090b76aab9 SHA512 7c940371a6c3ddbc4a6691edb6ee17eef61436912bb873c5c0cba4f3865c9d4f8e077674b14ccc7e319b749898782aaf87e085eedd9ba7f8638130deb67f549b WHIRLPOOL fcc82e25305a291f6884b2d18c8316b55902c6334962203c8b504e79a563e09173b7fa0da29276c12cf42e646a268d71b5dd6365990517379f211d1da343562e
diff --git a/dev-python/astor/astor-0.3.ebuild b/dev-python/astor/astor-0.3.ebuild
new file mode 100644
index 000000000000..f6d0c7ebfb9b
--- /dev/null
+++ b/dev-python/astor/astor-0.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/astor"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/astor/astor-0.4.1.ebuild b/dev-python/astor/astor-0.4.1.ebuild
new file mode 100644
index 000000000000..773c94c82ba7
--- /dev/null
+++ b/dev-python/astor/astor-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/astor"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/astor/astor-0.4.ebuild b/dev-python/astor/astor-0.4.ebuild
new file mode 100644
index 000000000000..c47e1ccbd619
--- /dev/null
+++ b/dev-python/astor/astor-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/astor"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/astor/astor-0.5.ebuild b/dev-python/astor/astor-0.5.ebuild
new file mode 100644
index 000000000000..773c94c82ba7
--- /dev/null
+++ b/dev-python/astor/astor-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/astor"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/astor/metadata.xml b/dev-python/astor/metadata.xml
new file mode 100644
index 000000000000..401f35c17dd4
--- /dev/null
+++ b/dev-python/astor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">astor</remote-id>
+ </upstream>
+</pkgmetadata>