summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-26 00:12:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-26 00:39:45 +0200
commit1434f31c9c5e47e00d31eddf29531fc5c5629905 (patch)
treea7d19aca898f66794980b5406f6a2d27c5fad1d1 /dev-python/astroid
parentRevert "media-libs/libsdl2: add USE flags hidapi, libusb" (diff)
downloadgentoo-1434f31c9c5e47e00d31eddf29531fc5c5629905.tar.gz
gentoo-1434f31c9c5e47e00d31eddf29531fc5c5629905.tar.bz2
gentoo-1434f31c9c5e47e00d31eddf29531fc5c5629905.zip
dev-python/astroid: Bump to 2.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.8.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 781058d8bfc7..3ca6b3a7af09 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -3,3 +3,4 @@ DIST astroid-2.7.3.tar.gz 378876 BLAKE2B 016ab6e798f1a608c0e0ce0bd81865145349c70
DIST astroid-2.8.0.tar.gz 384821 BLAKE2B 74150d67fd883b2bd4356c49c9c1b148a5e98b4d219405e745474c536691276d029bf8a0bb9275ab9df3d09a9b3492a147c67676ab1f80c9c7d3ad10f240bec4 SHA512 0f14f094a6dc753f0171b462f856fb1bfb1b979a8853f76da14beb04a5b02662f6b4e63c3241ce2c9a37f63490a86300152cbe9509c43e0209d5ef536d693b08
DIST astroid-2.8.2.tar.gz 388957 BLAKE2B 0e91b1978d8715f91b24e1d7f817bf7db3c4ca8c2c7af09f5df98b5a40c9307d54ec4051f08aa5062ffe51e5c396ae2e38078e1e124e23855fc207e34638719c SHA512 15b73c24517217ab54157d6568abf2c81c70e47980aece58eaf1d946e9d5d44316467ddaf2153fd8f6278cea80cfd09dc31783b215305c71c09d1e4e6f406862
DIST astroid-2.8.3.tar.gz 389855 BLAKE2B 355d6ae4a7c1bc9726e46a6eecf7538ecf91294220b10bcf4af26882b2c928544b6337c7368032587ba31bd0de19ed962d092bf8a783f74720d313b33fc96b90 SHA512 b93aed7a3092b726ef0d3e1b1703bf3e198d6eeea8d6faf40da8616d33a093f7e249dde930b85be7e0c358f5a151de12cad8571daa8cfc346d082670c556db08
+DIST astroid-2.8.4.tar.gz 391667 BLAKE2B 118a9dce88ac081d0057134cf4fb158fb8ca9c0d9807e9071910c86cad90c42518b7033a05504f617dcaf2cab73afe26be35224bf6b14aef618f77c15da07424 SHA512 8dc0746cabee8ae6f171d89df4ff2236b0f7c525694356e7169fb7ba5dc61a0febc04e4dfd1d116bc120170e5c70814b74df7625a2cce9b35aab40558bf6bd41
diff --git a/dev-python/astroid/astroid-2.8.4.ebuild b/dev-python/astroid/astroid-2.8.4.ebuild
new file mode 100644
index 000000000000..a7739e685def
--- /dev/null
+++ b/dev-python/astroid/astroid-2.8.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-1.14[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}