summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-18 07:50:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-18 07:54:44 +0200
commit46b703d342ea8bbf7a244f553664ca38d2f60cfd (patch)
tree2c1c5e1991d4dc92724e6e267123b42bc2eec02b /dev-python/astroid
parentdev-python/pip: Bump to 20.2.4 (diff)
downloadgentoo-46b703d342ea8bbf7a244f553664ca38d2f60cfd.tar.gz
gentoo-46b703d342ea8bbf7a244f553664ca38d2f60cfd.tar.bz2
gentoo-46b703d342ea8bbf7a244f553664ca38d2f60cfd.zip
dev-python/astroid: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/astroid-2.4.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/astroid/astroid-2.4.2.ebuild b/dev-python/astroid/astroid-2.4.2.ebuild
deleted file mode 100644
index 3ec264b0ee07..000000000000
--- a/dev-python/astroid/astroid-2.4.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
- >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.2-no-pytest-runner.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable failing tests
-
- sed -r -e 's:"(wrapt|six|lazy_object_proxy)(~|=)=.+":"\1":' \
- -i astroid/__pkginfo__.py || die
-
- # no idea why this test fails
- sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
- tests/unittest_modutils.py || die
-
- distutils-r1_python_prepare_all
-}