summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-21 09:22:51 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-21 09:33:31 +0100
commitc1db4351991b572d73ac7e1d50089aef18fea5e0 (patch)
tree5e7bb896f4b0f3d0f9a257af5a34c5e5a47c26af /dev-python/astroid
parentdev-python/humanfriendly: Version Bump (diff)
downloadgentoo-c1db4351991b572d73ac7e1d50089aef18fea5e0.tar.gz
gentoo-c1db4351991b572d73ac7e1d50089aef18fea5e0.tar.bz2
gentoo-c1db4351991b572d73ac7e1d50089aef18fea5e0.zip
dev-python/astroid: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-1.4.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 7860775ebadc..bfb31b135bf8 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -2,3 +2,4 @@ DIST astroid-1.3.8.tar.gz 155302 SHA256 3971c35c675dc7acfceb636eb1758b7df9fc3ad7
DIST astroid-1.4.1.tar.gz 179485 SHA256 2417a2c62f07bb77485efb6dd94567ac165808a4248ecb09754116662ffa9fc2 SHA512 5efc0235314cf68801ec4c4ca7688386bace0bbc5a0a92dffc6241d8fab69b5b7ddbe3385c1d909ebb2cb260174c93ce6f0408c3c0745ebbc7f6c1923a0ce59f WHIRLPOOL 7a2f5618d77eba504b7d1b8d39d3c488962d871d3b0ef5723d0bd5eb338cf7da8ce9d09a64e6c33ca22f175bcdf901f2d5f88df92cb3387d1a05dc810b3d12de
DIST astroid-1.4.2.tar.gz 181042 SHA256 b734fa504179a93aa03314df48b45fb1d9d0d8770a1126e7a126c9ac4aebd5c3 SHA512 faddbb830370232f4b3ea6cdd454da352a682b73062d9bac37ac28711dc6b17a071278d7b5019a7ba85ac4c1845752db42c0fe122be082bbc262a159b92276e2 WHIRLPOOL 18443d0dbfd6575836209c523b5d3c7eebf509a23395bb0e0e2bac43c117b3b2269c9bf6ddb4cfc896b1232f1f4d9a86ac3ebf40ba950a25070a8771e54cc7ac
DIST astroid-1.4.3.tar.gz 181329 SHA256 8e9ce4e925a17442cec085a7fce05478b99e482c13819c619b7cdd793777bf6b SHA512 a4c607ef16bda0561254fa177c319e6f139de12385a277e780c8db641a4aac3cc49712be3bf9b529609f3e303194d1caa7ba44b564662aaf32c6847aab4808d0 WHIRLPOOL 1086fed0948d8135970a951f5e2c2d2f8678e1b5169898f9df1407b40bbeea7dbcd80d16c759686ed5effd962e8c2054778873848e38545961c450b72bae9e9e
+DIST astroid-1.4.4.tar.gz 181733 SHA256 7f7e5512efe515098e77cbd3a60e87c8db8954097b0e025d8d6f72f2e8ddc298 SHA512 f78f749e9542145060ba997f2e46945c13cffda74fb77f05b358bf4c22bac8b9924889627148d205538f515413293733471d238fea62a084ab9727e8d239d6ce WHIRLPOOL 12aedaa9ad5c3cbffd641e292fc829e90ffc4aab30e35d7cdb71e88a3fcfb24a3fbda342adedddba4c3f72c3d96216a9cb6c58ad4f2183cdb0f4784dd21dd0b2
diff --git a/dev-python/astroid/astroid-1.4.4.ebuild b/dev-python/astroid/astroid-1.4.4.ebuild
new file mode 100644
index 000000000000..01531d5899d3
--- /dev/null
+++ b/dev-python/astroid/astroid-1.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# https://bitbucket.org/logilab/astroid/issues/276/testfailures-with-141
+RESTRICT=test
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# ${RDEPEND}
+# >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7)
+# )"
+# Required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
+}