summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 08:04:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 08:13:40 +0200
commitd1c168d51c1e670562c46ab64fa89009c99e6a76 (patch)
tree1db7142dae7a7369363564cb1d7d3117cfff8fe8 /dev-python/astroid
parentdev-python/Faker: Bump to 8.9.0 (diff)
downloadgentoo-d1c168d51c1e670562c46ab64fa89009c99e6a76.tar.gz
gentoo-d1c168d51c1e670562c46ab64fa89009c99e6a76.tar.bz2
gentoo-d1c168d51c1e670562c46ab64fa89009c99e6a76.zip
dev-python/astroid: Bump to 2.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.6.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index c60883051c5c..8ed5fcaeae89 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -3,3 +3,4 @@ DIST astroid-2.5.7.tar.gz 352082 BLAKE2B ca52339422da3a35cbe34e4b216dbfed3979dce
DIST astroid-2.5.8.tar.gz 354281 BLAKE2B 70ee47c26b765ba9f9bd40cf120a9ce13709043738e20a08d201cdb899789c6c6bdc604aaab49c78b2888503b46321a1728cce656f39d70ce6877ac088cb9567 SHA512 ab2f413e399810e98bd61c837ac90674e7c6d8e2f4d32f3141b21bf1360c785831fc4afd347e755c97627a04cb482aa4e455897e1c02eec8c5fcd28c54c1e9fc
DIST astroid-2.6.0.tar.gz 358265 BLAKE2B 77db092a9f4368f296a710235bd9d022638c97e3439195f01e55b38ff9e7cbfd204906c353a515ee0bc12f75526866d783ad57aa5d5f69e672e9c1603e48f579 SHA512 44e0833e078948eb1ba1e62710890be8cfc675f7ee136578a39e2914b082fcfbcb90b90a002998471fcd19c4092b9a3c5f71e58af32d3839fa799bcb5bf4a4ba
DIST astroid-2.6.1.tar.gz 360231 BLAKE2B 4f162f4a32741f36f97df93e1204a0cf9b4ff1d3203a9d0cd48da25e45ac3fcca642123e14e014da24418fa7b137b8bb863f6a4118b32193880e3994f63adca9 SHA512 2efa670edbb2317160c468465541a8a2e78b2fe09939f4d6da5f89516bbe121e347e883aac833aa14a70f20c98d889a414730db0ab836d84a78c91feb8d0ae5a
+DIST astroid-2.6.2.tar.gz 360787 BLAKE2B a2744b9ada601b731989f17ec75aa94d88825693a4ccf349374b8795b0db3879aa5bffe838df68759ff3296cd8af9cd45524e7d894a363f54055f3f1fa01e92e SHA512 776f8f9a12d425b7f048318b632dedb8894b6a3051a0607d1079437084aab4e9593e39cf9c7e01c2dd722364d2396cf13d7d26cc2acf33482d75584c458d4b89
diff --git a/dev-python/astroid/astroid-2.6.2.ebuild b/dev-python/astroid/astroid-2.6.2.ebuild
new file mode 100644
index 000000000000..316900df58b8
--- /dev/null
+++ b/dev-python/astroid/astroid-2.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}