summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 20:11:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 21:03:40 +0100
commitde846095529a052df0d6e027f330d35ba459b969 (patch)
tree5af7b51bec5c0d943ba6d8b2154b32b79890a3eb /dev-python/astroid
parentdev-python/Faker: Bump to 9.8.1 (diff)
downloadgentoo-de846095529a052df0d6e027f330d35ba459b969.tar.gz
gentoo-de846095529a052df0d6e027f330d35ba459b969.tar.bz2
gentoo-de846095529a052df0d6e027f330d35ba459b969.zip
dev-python/astroid: Bump to 2.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.8.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 3ca6b3a7af09..63ea38e41c56 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -4,3 +4,4 @@ DIST astroid-2.8.0.tar.gz 384821 BLAKE2B 74150d67fd883b2bd4356c49c9c1b148a5e98b4
DIST astroid-2.8.2.tar.gz 388957 BLAKE2B 0e91b1978d8715f91b24e1d7f817bf7db3c4ca8c2c7af09f5df98b5a40c9307d54ec4051f08aa5062ffe51e5c396ae2e38078e1e124e23855fc207e34638719c SHA512 15b73c24517217ab54157d6568abf2c81c70e47980aece58eaf1d946e9d5d44316467ddaf2153fd8f6278cea80cfd09dc31783b215305c71c09d1e4e6f406862
DIST astroid-2.8.3.tar.gz 389855 BLAKE2B 355d6ae4a7c1bc9726e46a6eecf7538ecf91294220b10bcf4af26882b2c928544b6337c7368032587ba31bd0de19ed962d092bf8a783f74720d313b33fc96b90 SHA512 b93aed7a3092b726ef0d3e1b1703bf3e198d6eeea8d6faf40da8616d33a093f7e249dde930b85be7e0c358f5a151de12cad8571daa8cfc346d082670c556db08
DIST astroid-2.8.4.tar.gz 391667 BLAKE2B 118a9dce88ac081d0057134cf4fb158fb8ca9c0d9807e9071910c86cad90c42518b7033a05504f617dcaf2cab73afe26be35224bf6b14aef618f77c15da07424 SHA512 8dc0746cabee8ae6f171d89df4ff2236b0f7c525694356e7169fb7ba5dc61a0febc04e4dfd1d116bc120170e5c70814b74df7625a2cce9b35aab40558bf6bd41
+DIST astroid-2.8.5.tar.gz 393800 BLAKE2B eb3e7abe877da8054dd9e5bbad89e23e8cc6bfdb5c224674c1559d0bf6fbdfd562ef33d65457b26394fc9de38f77e5ce3c15509d71993d0d07ddfd00b97fbcd2 SHA512 4dcad05763419db2814c4e6a8f0a9b62d967e8855ac77a3cedf90f6186d5c68bcf037ac36e4af8dfcbaad3abab3b8ec2485a5973f5ac1952971c335a827948ce
diff --git a/dev-python/astroid/astroid-2.8.5.ebuild b/dev-python/astroid/astroid-2.8.5.ebuild
new file mode 100644
index 000000000000..a7739e685def
--- /dev/null
+++ b/dev-python/astroid/astroid-2.8.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-1.14[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}