summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-11 18:09:13 +0000
committerSam James <sam@gentoo.org>2020-09-11 18:09:22 +0000
commit5da5883bc9a2c0781bda69c8c73c1f05fdd9a56e (patch)
treed454829c206538b077e2da2b30a9e3232e59fda9 /dev-python/asttokens
parentdev-python/redlock-py: Remove self as maintainer (diff)
downloadgentoo-5da5883bc9a2c0781bda69c8c73c1f05fdd9a56e.tar.gz
gentoo-5da5883bc9a2c0781bda69c8c73c1f05fdd9a56e.tar.bz2
gentoo-5da5883bc9a2c0781bda69c8c73c1f05fdd9a56e.zip
dev-python/asttokens: strip dev-python/wheel 'dep'
We don't actually build the wheel, so strip it out of setup.cfg to avoid build failures where it's not on the system. Closes: https://bugs.gentoo.org/741692 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/asttokens')
-rw-r--r--dev-python/asttokens/asttokens-2.0.4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/asttokens/asttokens-2.0.4.ebuild b/dev-python/asttokens/asttokens-2.0.4.ebuild
index 1cb502acd191..ee9e23b95435 100644
--- a/dev-python/asttokens/asttokens-2.0.4.ebuild
+++ b/dev-python/asttokens/asttokens-2.0.4.ebuild
@@ -28,6 +28,13 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+src_prepare() {
+ # Kill off useless wheel dep
+ sed -i -e 's/wheel; //' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
local deselect=()
[[ ${EPYTHON} == python3.9 ]] && deselect+=(