summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-07 09:50:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-07 11:33:38 +0200
commit3c95b611a04650d832f93f425512d1baa40561f1 (patch)
tree6eef4c64f6d3c57f34e34739316c917ed0ac1136 /dev-python/async-lru
parentapp-admin/awscli: Bump to 1.23.9 (diff)
downloadgentoo-3c95b611a04650d832f93f425512d1baa40561f1.tar.gz
gentoo-3c95b611a04650d832f93f425512d1baa40561f1.tar.bz2
gentoo-3c95b611a04650d832f93f425512d1baa40561f1.zip
dev-python/async-lru: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async-lru')
-rw-r--r--dev-python/async-lru/Manifest1
-rw-r--r--dev-python/async-lru/async-lru-1.0.3.ebuild39
-rw-r--r--dev-python/async-lru/metadata.xml2
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
index f97e0cc563ec..5739bca78222 100644
--- a/dev-python/async-lru/Manifest
+++ b/dev-python/async-lru/Manifest
@@ -1 +1,2 @@
+DIST async-lru-1.0.3.gh.tar.gz 10709 BLAKE2B 437880c419d0d8df5c790ff9b93d0b608dacba1847fc0974d35f89ff97bdd07589edc5371c729889791cb05cd8ec684764ecedc6d0d36b05ee930f885570095c SHA512 530c6e1f7a1ecc8a78cac927ccb9dfc2e394498a6ed3f54e73e4e9af48ef26ddeaad56a056a50b3c3974324af69b393cd94b1f4d20e3a2944b217c03a6bd6394
DIST async-lru-17a5d207f603c0c142f01a69fbf6f487b3fef5c4.tar.gz 10486 BLAKE2B 88831686b79ed742d28a202b1b303333c52b604f6e786cd0bccc4141a81d002a2b2daf3a264bf83d40e5218a3aa3209579d99b9e1b358da708ffada50bea2d3e SHA512 3c92b5c2fe149e53889f9c4adba9b88a03815d563b56d45363310c2527d4ebb800147fc8e38847f4b473d424692bfae55f96e482979009fb1a977850fb08b2f1
diff --git a/dev-python/async-lru/async-lru-1.0.3.ebuild b/dev-python/async-lru/async-lru-1.0.3.ebuild
new file mode 100644
index 000000000000..7863461b3f70
--- /dev/null
+++ b/dev-python/async-lru/async-lru-1.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.2.4[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cache-clear::' \
+ -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/async-lru/metadata.xml b/dev-python/async-lru/metadata.xml
index 633af0cf4ad6..705bfa8fd43b 100644
--- a/dev-python/async-lru/metadata.xml
+++ b/dev-python/async-lru/metadata.xml
@@ -7,6 +7,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="github">aio-libs/async-lru</remote-id>
- <remote-id type="pypi">async_lru</remote-id>
+ <remote-id type="pypi">async-lru</remote-id>
</upstream>
</pkgmetadata>