summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-08-28 12:24:03 -0700
committerZac Medico <zmedico@gentoo.org>2019-08-28 12:26:04 -0700
commit6a49dca30899af7582e58d9adf584117caa97019 (patch)
tree014cd62f7e9f52a4769d034c6dddac285874f77a /dev-python/async_timeout
parentgui-libs/wlroots: add subslots for wlroots (diff)
downloadgentoo-6a49dca30899af7582e58d9adf584117caa97019.tar.gz
gentoo-6a49dca30899af7582e58d9adf584117caa97019.tar.bz2
gentoo-6a49dca30899af7582e58d9adf584117caa97019.zip
dev-python/async_timeout: Re-add version 1.2.1 for gns3-server
net-misc/gns3-server-2.1.21 requires <dev-python/async_timeout-3.0.0 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout')
-rw-r--r--dev-python/async_timeout/Manifest1
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index f929a7fd11ef..4929a35b0dba 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -1 +1,2 @@
+DIST async-timeout-1.2.1.tar.gz 7797 BLAKE2B d8f736423631a2b2c0fb748eb2857e0f9a143af9591ddfae15d42ab13af33196a6624db5b0a705265269ed28c6c15a4e8cfe56143ccedac75a555ae62a82891b SHA512 2072caeb65a74f1a24b59a4ea905ef96d70f8fb117e3dd9c95c1107b1d67ffaa4d76b68f00364049e6e29cdb0a6d247ba0c3638ccd0a8db27bd6ee0f180f9ccb
DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
diff --git a/dev-python/async_timeout/async_timeout-1.2.1.ebuild b/dev-python/async_timeout/async_timeout-1.2.1.ebuild
new file mode 100644
index 000000000000..22db4f22c785
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i "s:, 'pytest-runner'::" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}