summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 10:52:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 11:07:41 +0100
commit759a643ab1e8cc31a46c868df2b5d321ae02aff8 (patch)
tree1d2b7420ee984830225a1f3e99ed6cb9e6219b64 /dev-python/async_timeout
parentmedia-sound/xmms2: Fix build with Py3.{7,8} by using newer Waf (diff)
downloadgentoo-759a643ab1e8cc31a46c868df2b5d321ae02aff8.tar.gz
gentoo-759a643ab1e8cc31a46c868df2b5d321ae02aff8.tar.bz2
gentoo-759a643ab1e8cc31a46c868df2b5d321ae02aff8.zip
dev-python/async_timeout: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout')
-rw-r--r--dev-python/async_timeout/Manifest1
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.1.ebuild32
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index 5362dd29f094..eb9bc6d772a8 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -1,3 +1,2 @@
-DIST async-timeout-1.2.1.tar.gz 7797 BLAKE2B d8f736423631a2b2c0fb748eb2857e0f9a143af9591ddfae15d42ab13af33196a6624db5b0a705265269ed28c6c15a4e8cfe56143ccedac75a555ae62a82891b SHA512 2072caeb65a74f1a24b59a4ea905ef96d70f8fb117e3dd9c95c1107b1d67ffaa4d76b68f00364049e6e29cdb0a6d247ba0c3638ccd0a8db27bd6ee0f180f9ccb
DIST async-timeout-2.0.1.tar.gz 10463 BLAKE2B a9c1ab7ffd249f1d4d07a37f07743923a890d11bb9ff913b37f45e9f7be1110eba9cd24ce741b71a353ae349aceccd66a1853ed985416a85cdb4faa46f341681 SHA512 cb66bdc286082ef5570a7e3aa420434f82bb4131e9527c499c693a21d72b3f3772922c0ce2ad68e7de5f95960061e508effda56be398356ea75d55272f534a86
DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
diff --git a/dev-python/async_timeout/async_timeout-1.2.1.ebuild b/dev-python/async_timeout/async_timeout-1.2.1.ebuild
deleted file mode 100644
index c0504b87b044..000000000000
--- a/dev-python/async_timeout/async_timeout-1.2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-S=${WORKDIR}/${MY_P}
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i "s:, 'pytest-runner'::" -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}