summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-14 08:35:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-14 09:18:51 +0200
commitb4862f341669807030631b4e46c682b680e9259a (patch)
tree102b5f5985b7b39f434357afd18c23fcf2bc4f2d /dev-python/atpublic/atpublic-2.3.ebuild
parentdev-python/decorator: Bump to 5.0.7 (diff)
downloadgentoo-b4862f341669807030631b4e46c682b680e9259a.tar.gz
gentoo-b4862f341669807030631b4e46c682b680e9259a.tar.bz2
gentoo-b4862f341669807030631b4e46c682b680e9259a.zip
dev-python/atpublic: Bump to 2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/atpublic/atpublic-2.3.ebuild')
-rw-r--r--dev-python/atpublic/atpublic-2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/atpublic/atpublic-2.3.ebuild b/dev-python/atpublic/atpublic-2.3.ebuild
new file mode 100644
index 000000000000..81e2361f4d03
--- /dev/null
+++ b/dev-python/atpublic/atpublic-2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="https://gitlab.com/warsaw/public"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=public::' setup.cfg || die
+ distutils-r1_src_prepare
+}