summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 15:35:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 19:05:36 +0200
commit1d94e1bfb4cf345b6c3f47962b9885a416b378f6 (patch)
tree7a10ad9dab5aa535a08ff2a63552e59ec78ea629 /dev-python/attrs
parentdev-python/py: Enable python3.10 (diff)
downloadgentoo-1d94e1bfb4cf345b6c3f47962b9885a416b378f6.tar.gz
gentoo-1d94e1bfb4cf345b6c3f47962b9885a416b378f6.tar.bz2
gentoo-1d94e1bfb4cf345b6c3f47962b9885a416b378f6.zip
dev-python/attrs: Bump to 20.3.0_p20210222 snapshot for py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-20.3.0_p20210222.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index a3541fe64ce9..09494bc15e8d 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1 +1,2 @@
+DIST attrs-03d3fc7a71fe770e1f86b9c3ad8588586e5ea63b.tar.gz 170688 BLAKE2B 1256cb115b3613929f9caf7f31907a51c9afdd5f6e0a10a172089e920d6604c41db3fb11726ab71a698b4ff9e6420e827d5ff25c4127ef7c6cf12536a66a9bb3 SHA512 3007f8c502c0bcd2481ffbbb00bec4ed677d1be9514e417670c4adb791dc67eee76b8a7c07a4a972cd4ece3291e2c996944bb1cdb282682086551cbd571a0011
DIST attrs-20.3.0.tar.gz 164523 BLAKE2B 66d2e038e485833f5033fbabe2ef9a6565e3f5f5e8530f2c70019e4f5bdfca51083ac6d0bbc9eb765f838070bc90e01db1c83ed6da113ced67300238e12b5f42 SHA512 640532c6b763fd96572e5d85e93c111bebc4c5e0ff9419fe92fb51280f03acb5f9f43339f57d30659e777d5578460675c60ec0a362f9ad433893e3624ce6a931
diff --git a/dev-python/attrs/attrs-20.3.0_p20210222.ebuild b/dev-python/attrs/attrs-20.3.0_p20210222.ebuild
new file mode 100644
index 000000000000..33b6eb24790b
--- /dev/null
+++ b/dev-python/attrs/attrs-20.3.0_p20210222.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+EGIT_COMMIT=03d3fc7a71fe770e1f86b9c3ad8588586e5ea63b
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="
+ https://github.com/python-attrs/attrs/archive/${EGIT_COMMIT}.tar.gz
+ -> ${PN}-${EGIT_COMMIT}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest