summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-01-03 17:06:19 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-01-03 17:08:00 +0100
commit973c3282b0e5d924900ccb653431dd15aab66a7c (patch)
tree3f3eb9b0f6af5c5e04bce6e17424b25336bd2560 /dev-python/autobahn
parentdev-python/txaio: Bump (diff)
downloadgentoo-973c3282b0e5d924900ccb653431dd15aab66a7c.tar.gz
gentoo-973c3282b0e5d924900ccb653431dd15aab66a7c.tar.bz2
gentoo-973c3282b0e5d924900ccb653431dd15aab66a7c.zip
dev-python/autobahn: Bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-0.11.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index ed6a65c1cdab..e6a9769ed0a4 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,2 +1,3 @@
DIST autobahn-0.10.4.tar.gz 148147 SHA256 3dd7a7793cead942cb0c06bef5a9f69e64edc174e47fb822702eafd41085933d SHA512 1eb43df9b0c986f1788c6463875765266cfc562155399c326b4e9bf447119fbfc967dcc53f8f8844700d21ebf37df6c596ead8c105918af5c6a8ec09585ce797 WHIRLPOOL b5be6d7f6348dc627fcbd2c60699cbd60e3e14e6494f787275d3890c30bca5804783b7a010faab5d19d19097ac90ddfdfdb1a3aaf6d37e4daef943916bf5422f
+DIST autobahn-0.11.0.tar.gz 149680 SHA256 e7aea216e2a3bb41a4fec235399ece8bfbc0be4ef9567e1ed6927db7fa35f851 SHA512 9f53e2ef7637ddf9aec263fa2db8977c5b7a0d8a1bea6b21c030660d5d17e343cab5f84ebda8b0f97d55e1e4a77a0313805294a3a1487fce004c10a4cddfdc86 WHIRLPOOL f5ade4fc98a14585a8ee9a3e4141a6739668d402ff8c4fd42854062c01de33492093752e08a000f708bef232ce30039b51e0c53553f779da898ef526c861315f
DIST autobahn-0.9.4-2.zip 175894 SHA256 5bb64191cfdd1cbdd90d8e359b389ef62c0acdffd2f68d16ec01fa0a287262f0 SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5 WHIRLPOOL aa0f06b82acbebb97ca2e3c424429ada7169dca5b39237ce082a17440ec9701a307e9fc7f162f957023cfc4c067f8e8b82b9923cb056ffcab7b3e64a61a4aae8
diff --git a/dev-python/autobahn/autobahn-0.11.0.ebuild b/dev-python/autobahn/autobahn-0.11.0.ebuild
new file mode 100644
index 000000000000..4df31003b5e1
--- /dev/null
+++ b/dev-python/autobahn/autobahn-0.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+RESTRICT="test"
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep 'virtual/python-asyncio[${PYTHON_USEDEP}]' 'python3*')
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/trollius-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-11.1[$(python_gen_usedep 'python2*')]
+ >=dev-python/txaio-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ujson-1.33[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ esetup.py test
+}