summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-13 13:24:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-13 13:24:08 +0200
commit69837b616e805bf80b5917b776d2beb8637fb217 (patch)
treefe5c0f810261b3be74fc9aaa2381c9eb38e0de8e /dev-python/automat
parentdev-python/jsonpickle: Remove old (diff)
downloadgentoo-69837b616e805bf80b5917b776d2beb8637fb217.tar.gz
gentoo-69837b616e805bf80b5917b776d2beb8637fb217.tar.bz2
gentoo-69837b616e805bf80b5917b776d2beb8637fb217.zip
dev-python/automat: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/automat')
-rw-r--r--dev-python/automat/automat-20.2.0.ebuild62
-rw-r--r--dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch27
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/automat/automat-20.2.0.ebuild b/dev-python/automat/automat-20.2.0.ebuild
deleted file mode 100644
index b4084934543a..000000000000
--- a/dev-python/automat/automat-20.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="A${PN:1}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Self-service finite-state machines for the programmer on the go"
-HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/automat-0.8.0-no-setup-py-m2r-import.patch"
- "${FILESDIR}/test_visualize-twisted-import-errors.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if use test ; then
- # Remove since this is upstream benchmarking tests
- rm -r benchmark || die "FAILED to remove benchmark tests"
- fi
-
- # avoid a setuptools_scm dependency
- sed -r -i "s:use_scm_version=True:version='${PV}': ;
- s:[\"']setuptools[_-]scm[\"'](,|)::" setup.py || die
- # strip m2r dep
- sed -i -e "/'m2r'/d" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc docs/examples/*.py
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "For additional visualization functionality install both these optional dependencies"
- einfo " >=dev-python/twisted-16.1.1"
- einfo " media-gfx/graphviz[python]"
-}
diff --git a/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch b/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch
deleted file mode 100644
index 161b219626da..000000000000
--- a/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/setup.py b/setup.py
-index d0dec04..7a85a6e 100644
---- a/setup.py
-+++ b/setup.py
-@@ -4,14 +4,6 @@ Setup file for automat
-
- from setuptools import setup, find_packages
-
--try:
-- from m2r import parse_from_file
-- long_description = parse_from_file('README.md')
--except(IOError, ImportError):
-- print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n")
-- import io
-- long_description = io.open('README.md', encoding="utf-8").read()
--
- setup(
- name='Automat',
- use_scm_version=True,
-@@ -19,7 +11,6 @@ setup(
- description="""
- Self-service finite-state machines for the programmer on the go.
- """.strip(),
-- long_description=long_description,
- packages=find_packages(exclude=[]),
- package_dir={'automat': 'automat'},
- setup_requires=[