summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-18 01:48:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-18 01:50:05 -0500
commitb0d3d2dd8cb97fa93374e7c0b094d0f03b97434c (patch)
tree8fcdc53e6ad4c10a409b97d5464d562c14e2869c /dev-python/automaton/automaton-0.8.0.ebuild
parentdev-vcs/git: Stable for PPC64 (bug #562884). (diff)
downloadgentoo-b0d3d2dd8cb97fa93374e7c0b094d0f03b97434c.tar.gz
gentoo-b0d3d2dd8cb97fa93374e7c0b094d0f03b97434c.tar.bz2
gentoo-b0d3d2dd8cb97fa93374e7c0b094d0f03b97434c.zip
dev-python/automaton: adding for liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/automaton/automaton-0.8.0.ebuild')
-rw-r--r--dev-python/automaton/automaton-0.8.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/automaton/automaton-0.8.0.ebuild b/dev-python/automaton/automaton-0.8.0.ebuild
new file mode 100644
index 000000000000..bb05c73d3559
--- /dev/null
+++ b/dev-python/automaton/automaton-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendly state machines for python."
+HOMEPAGE="https://pypi.python.org/pypi/automaton"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8.0[${PYTHON_USEDEP}]"