summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-10 08:51:46 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:27 +0100
commitf360f79329c6bc6d9294e6ebf79266ff03727036 (patch)
treec37b789e3406935f4082cb69b94a37efb61af5e6 /dev-python/autopep8/autopep8-1.4.4.ebuild
parentdev-python/pydiff: add python3_8 (diff)
downloadgentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.tar.gz
gentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.tar.bz2
gentoo-f360f79329c6bc6d9294e6ebf79266ff03727036.zip
dev-python/autopep8: bump v1.4.4
remove dev-python/pep8 dependency add python3_7,python3_8 support use distutils_enable_tests for tests Closes: https://bugs.gentoo.org/697084 Closes: https://bugs.gentoo.org/677074 Closes: https://bugs.gentoo.org/660446 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8/autopep8-1.4.4.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.4.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.4.4.ebuild b/dev-python/autopep8/autopep8-1.4.4.ebuild
new file mode 100644
index 000000000000..eda59462a420
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py