summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-14 11:51:14 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-14 11:51:14 +0200
commit63610a4fec8fdc1e57925b71d0196f82462a89a7 (patch)
treedf71ba886fc6595dab4d993d0debcd1a4ce451c0 /dev-python/autopep8/autopep8-1.5.4.ebuild
parentdev-python/pydiff: Add python 3.9 (diff)
downloadgentoo-63610a4fec8fdc1e57925b71d0196f82462a89a7.tar.gz
gentoo-63610a4fec8fdc1e57925b71d0196f82462a89a7.tar.bz2
gentoo-63610a4fec8fdc1e57925b71d0196f82462a89a7.zip
dev-python/autopep8: Version bump to 1.5.4
Bug: https://bugs.gentoo.org/737866 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/autopep8/autopep8-1.5.4.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.5.4.ebuild b/dev-python/autopep8/autopep8-1.5.4.ebuild
new file mode 100644
index 000000000000..4ebce4805b38
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py