summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-30 09:12:26 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-30 14:22:03 +0200
commita82f497fbfe6209d451e9277b8301a99a825a82c (patch)
tree2b2233c4aabba853c2fc90a0e7e77df8225a9972 /dev-python/autopep8
parentdev-libs/libinput: Bump to version 1.17.2 (diff)
downloadgentoo-a82f497fbfe6209d451e9277b8301a99a825a82c.tar.gz
gentoo-a82f497fbfe6209d451e9277b8301a99a825a82c.tar.bz2
gentoo-a82f497fbfe6209d451e9277b8301a99a825a82c.zip
dev-python/autopep8: Bump to 1.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.5.7.ebuild29
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 21d19cee472c..7722026c356b 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1,3 @@
DIST autopep8-1.5.5.tar.gz 117991 BLAKE2B 74e9bfed663d68f4a73088fccd879c538d40c564e7527b067d549a15361dfba2adcb853a8895fc61da50972f947ce23900f8067f5b8e715f73d6a80c6c27ef5b SHA512 9982271805131a7330d4a2a46eda65c05f079925393686f2df7eb92dc9e172003f9d788663cb8c0c8849dbae4f64c518c310eb65c3df308a12700abab084c39c
DIST autopep8-1.5.6.tar.gz 121134 BLAKE2B aefeb4cc53ac66fb6eaef4d7af286d6249e7139e5409fe6f6b3568f0c6216d758dd73a950d043e36b6f19cf5de83f62e28ca318c45a7e40ffdeac0f7a9e06cdf SHA512 d283c3e2021025097c6b2f95faf7db12664b7d1f69f82acf9fe94e20fbd49cfcb28ad47437aa3148503c59cf5c2690a842fd795f869731290c80dc9feb86637b
+DIST autopep8-1.5.7.tar.gz 121537 BLAKE2B 06f107cab210258fe71b8e912312520797122fd38e3e67fa0d6cf640806690e1255fec63c74c11ec39952a4a50964a3f622ca1166d29299c4f7a7031a1013202 SHA512 b8fb8b63400e74ea978f576cb47c99b0a4bb15a5d1cfeb6ffc25d2ecdad301762f99ddff5c75af3900b3560797d9289a15bbb87ddcf74077d39bde0abadd4da7
diff --git a/dev-python/autopep8/autopep8-1.5.7.ebuild b/dev-python/autopep8/autopep8-1.5.7.ebuild
new file mode 100644
index 000000000000..809832964cc6
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index a3edf664463a..11848b6f772e 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{7..9} pypy3 )
PYTHON_REQ_USE="threads(+)"