summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-28 00:42:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-28 00:47:20 +0200
commit3ccf7a7ec3f6aa9b4350d75f9834ca52cd654b53 (patch)
tree267d7bda344df3bdfb77e4d06b6849945424d3af /dev-python/autoprop
parentdev-python/signature_dispatch: Enable py3.10 (diff)
downloadgentoo-3ccf7a7ec3f6aa9b4350d75f9834ca52cd654b53.tar.gz
gentoo-3ccf7a7ec3f6aa9b4350d75f9834ca52cd654b53.tar.bz2
gentoo-3ccf7a7ec3f6aa9b4350d75f9834ca52cd654b53.zip
dev-python/autoprop: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autoprop')
-rw-r--r--dev-python/autoprop/Manifest1
-rw-r--r--dev-python/autoprop/autoprop-3.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
index 69e9407074ff..0a786c30ba92 100644
--- a/dev-python/autoprop/Manifest
+++ b/dev-python/autoprop/Manifest
@@ -3,3 +3,4 @@ DIST autoprop-2.0.0.tar.gz 11705 BLAKE2B 0dd6401671250f9445aaaf20345035bec683eb7
DIST autoprop-2.1.0.tar.gz 13258 BLAKE2B a08431a87067463278276974326ca81a8c0150193fd3a03fdc2ab422b836655a11f759154fdeeaf834bc379163e167d4815358aaefdc83a76ab4dfa87b6efee5 SHA512 c30ee4bf85d139abf1be2e7b0217bc6f394ba289ccdad423c97f1d27f472ce00eaef2be0f3cdf1c9022c6edc56006d5834d1afd6ef2c5ee2ec124eb5bf679652
DIST autoprop-2.1.1.tar.gz 13794 BLAKE2B 63645d0d8f9d49f5df730dca18c468e3dea7108e01cf12f6de6d80ad6cf8b5d396957d4a0cd82c737c0b12274a8534e6f48120ef1118c0fb34dba529dc74f081 SHA512 39db6c1130d0b958713f15efcd75ecbbb41659f5f7182be37f1dca22a46c18832d0f7893fadfbf4e8ad9f446417a2476e7dc7890124c9caabd6b5dde37eb7c6f
DIST autoprop-2.2.0.tar.gz 13939 BLAKE2B b30565618cab67c5a3b9f94958a8f4734d60c048067f73a007fdb9d34555337f92776cac221c89e0067851d59b21f157b4bc1d24fdcaf3e3ae677c31c8a32cc9 SHA512 d8ef758b0d097ddb73cb384075d3d2b0d59191cd12d59a54cc449483da94ab116c75b39cf48d3d262b147e855af1806a0c617ba220f435118d636cd6f283c51e
+DIST autoprop-3.0.0.tar.gz 14082 BLAKE2B 9881dd924b8d66e83dccb3e7ca1d753bec924e8f348d96d0522a76e857c85311ef7ada37b0080c1b3a0e719bf84e807d12c7e4dff4bbfc111273b340f92244a5 SHA512 4730155130b98fc02bea991837ee6d875f19ffa14ae542909314264950d20a34cdbff9e21b31431136624de0dac5eb2a50a9cf677da01862b38cae9c10bec92f
diff --git a/dev-python/autoprop/autoprop-3.0.0.ebuild b/dev-python/autoprop/autoprop-3.0.0.ebuild
new file mode 100644
index 000000000000..6a1d42d9b3be
--- /dev/null
+++ b/dev-python/autoprop/autoprop-3.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/signature_dispatch[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest