summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 08:46:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:32 +0200
commitd87f70e0198fecaf04ae7b114cfd9520bfd376b3 (patch)
treeeab79d034a2e7d7a9aa02586ea5510192306ce3e /dev-python/autoprop
parentdev-python/boto3: Bump to 1.17.45 (diff)
downloadgentoo-d87f70e0198fecaf04ae7b114cfd9520bfd376b3.tar.gz
gentoo-d87f70e0198fecaf04ae7b114cfd9520bfd376b3.tar.bz2
gentoo-d87f70e0198fecaf04ae7b114cfd9520bfd376b3.zip
dev-python/autoprop: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autoprop')
-rw-r--r--dev-python/autoprop/Manifest1
-rw-r--r--dev-python/autoprop/autoprop-2.2.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
index ae49e5bef90b..69e9407074ff 100644
--- a/dev-python/autoprop/Manifest
+++ b/dev-python/autoprop/Manifest
@@ -2,3 +2,4 @@ DIST autoprop-1.0.2.tar.gz 11040 BLAKE2B b53bdbf79947002a0c319fa84c6033908948365
DIST autoprop-2.0.0.tar.gz 11705 BLAKE2B 0dd6401671250f9445aaaf20345035bec683eb7e7e3889ee6c89bbefd76bff9112c848ab4b95c47f09f2487af92c3c6a3404be17bc57f47c9be33f36ec369175 SHA512 7e2f9d2d950ac8f2b0e73b483940590dbb6eb342a36204cc36fff219375eb223c62d5c0dc864b0d1212593919f1625cd282f0467a5bf84d5c1e5c158cfcf6cc1
DIST autoprop-2.1.0.tar.gz 13258 BLAKE2B a08431a87067463278276974326ca81a8c0150193fd3a03fdc2ab422b836655a11f759154fdeeaf834bc379163e167d4815358aaefdc83a76ab4dfa87b6efee5 SHA512 c30ee4bf85d139abf1be2e7b0217bc6f394ba289ccdad423c97f1d27f472ce00eaef2be0f3cdf1c9022c6edc56006d5834d1afd6ef2c5ee2ec124eb5bf679652
DIST autoprop-2.1.1.tar.gz 13794 BLAKE2B 63645d0d8f9d49f5df730dca18c468e3dea7108e01cf12f6de6d80ad6cf8b5d396957d4a0cd82c737c0b12274a8534e6f48120ef1118c0fb34dba529dc74f081 SHA512 39db6c1130d0b958713f15efcd75ecbbb41659f5f7182be37f1dca22a46c18832d0f7893fadfbf4e8ad9f446417a2476e7dc7890124c9caabd6b5dde37eb7c6f
+DIST autoprop-2.2.0.tar.gz 13939 BLAKE2B b30565618cab67c5a3b9f94958a8f4734d60c048067f73a007fdb9d34555337f92776cac221c89e0067851d59b21f157b4bc1d24fdcaf3e3ae677c31c8a32cc9 SHA512 d8ef758b0d097ddb73cb384075d3d2b0d59191cd12d59a54cc449483da94ab116c75b39cf48d3d262b147e855af1806a0c617ba220f435118d636cd6f283c51e
diff --git a/dev-python/autoprop/autoprop-2.2.0.ebuild b/dev-python/autoprop/autoprop-2.2.0.ebuild
new file mode 100644
index 000000000000..37bed53e6f45
--- /dev/null
+++ b/dev-python/autoprop/autoprop-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/signature_dispatch[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest