summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 14:01:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 14:14:38 +0200
commite6844a2c1a196cdafa304acf7be2c1e668553b4d (patch)
tree27948130f7f35a39c7585db51b9f76d11c6fb9d8 /dev-python/babelfish/babelfish-0.6.0-r1.ebuild
parentdev-python/pyproject2setuppy: Bump to v20 (diff)
downloadgentoo-e6844a2c1a196cdafa304acf7be2c1e668553b4d.tar.gz
gentoo-e6844a2c1a196cdafa304acf7be2c1e668553b4d.tar.bz2
gentoo-e6844a2c1a196cdafa304acf7be2c1e668553b4d.zip
dev-python/babelfish: Require pyproject2setuppy-20
Closes: https://bugs.gentoo.org/808486 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/babelfish/babelfish-0.6.0-r1.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-0.6.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/babelfish/babelfish-0.6.0-r1.ebuild b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..69cb0c404508
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="
+ https://github.com/Diaoul/babelfish/
+ https://pypi.org/project/babelfish/"
+SRC_URI="
+ https://github.com/Diaoul/babelfish/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest