summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-06-06 02:01:45 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-06 23:38:45 +0200
commite819efd10e7ef9b8db0e4a56a4f34d152bea1d77 (patch)
treee948dbb12c363ca5c10aea273e76eddeb46bf748 /dev-python/backports-functools-lru-cache
parentdev-vcs/git: bump. (diff)
downloadgentoo-e819efd10e7ef9b8db0e4a56a4f34d152bea1d77.tar.gz
gentoo-e819efd10e7ef9b8db0e4a56a4f34d152bea1d77.tar.bz2
gentoo-e819efd10e7ef9b8db0e4a56a4f34d152bea1d77.zip
dev-python/backports-functools-lru-cache: version bump to 1.4 and fix doc build.
Gentoo-Bug: https://bugs.gentoo.org/619028 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4864
Diffstat (limited to 'dev-python/backports-functools-lru-cache')
-rw-r--r--dev-python/backports-functools-lru-cache/Manifest1
-rw-r--r--dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/backports-functools-lru-cache/Manifest b/dev-python/backports-functools-lru-cache/Manifest
index 74da02cff121..81ac1051ba76 100644
--- a/dev-python/backports-functools-lru-cache/Manifest
+++ b/dev-python/backports-functools-lru-cache/Manifest
@@ -1,2 +1,3 @@
DIST backports.functools_lru_cache-1.2.1.tar.gz 5763 SHA256 1c20e07f1a8a36a19d5d258b6b076e588d78d8fc7c2c4487ffe3a280f55a7bd1 SHA512 e15e6bbddf252ed48f787a26c9ef693ccceb8ec5b3463f0926d58a1d2720b988cd86b869ec72afc66369a7968316b9eb3ae0b628f1c63a116c2360900df85691 WHIRLPOOL 4d604f38e659117230e58180c6996e1f7b0f1d7c580ffcb5dde947e0d11078989b695fbd50672e65baac6f0bb4fb7612f506084d7589adf4f37720e70fded367
DIST backports.functools_lru_cache-1.3.tar.gz 6685 SHA256 444a21bcec4ae177da554321f81a78dc879eaa8f6ea9920cb904830585d31e95 SHA512 946156266d4b1bccb3eb444d1cceff6568b8c2a62e09bc9197281bdafe912069efa4c857089a7e6ea0247ab9407256a7a7c92485599692e0c0159c428137a342 WHIRLPOOL a4cccbfd49acc640c1e15949919e10343c00f966e22bac7a2dc82af776f35cadce825a7757c5dca32b189797303abedc93aecf3000203819ee869bbb37ac4a03
+DIST backports.functools_lru_cache-1.4.tar.gz 6927 SHA256 31f235852f88edc1558d428d890663c49eb4514ffec9f3650e7f3c9e4a12e36f SHA512 78dcd12f392bc110d1556f567a9f8fe977fa4ddc98a2121ceaf43606687171866832b8d32220dfb4ca335f53e89acecabda9e48ad48571f1741b21ab2d3b8a21 WHIRLPOOL a223576df439818a247784e49d1d401807955a64eee4fdae9b937daaa96afc42e535819b4f6bbd0aaf04a0764a241809a79909ecda359ede60891dfb33305414
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4.ebuild
new file mode 100644
index 000000000000..a91b8b0f4d9b
--- /dev/null
+++ b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_PN="${MY_PN//-/_}"
+DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
+HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # avoid a collision with dev-python/backports
+ find "${D}" -path '*/backports/__init__.py' -delete || die
+}