summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-31 15:09:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-31 15:09:53 +0200
commit1cb70290dceaa7302f1e10d245a2923678517dca (patch)
tree2da19b1ba11ec2a2f0a27f129eb568af33509f2e /dev-python/backrefs
parentdev-python/sphinx-notfound-page: Bump to 1.0.0 (diff)
downloadgentoo-1cb70290dceaa7302f1e10d245a2923678517dca.tar.gz
gentoo-1cb70290dceaa7302f1e10d245a2923678517dca.tar.bz2
gentoo-1cb70290dceaa7302f1e10d245a2923678517dca.zip
dev-python/backrefs: Bump to 5.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/backrefs')
-rw-r--r--dev-python/backrefs/Manifest1
-rw-r--r--dev-python/backrefs/backrefs-5.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/backrefs/Manifest b/dev-python/backrefs/Manifest
index 4d15e056d1c2..290e5735f28d 100644
--- a/dev-python/backrefs/Manifest
+++ b/dev-python/backrefs/Manifest
@@ -1 +1,2 @@
+DIST backrefs-5.5.1.gh.tar.gz 5401854 BLAKE2B 5aab7fa4d2b74ca250e93aa6085dfa7302525c2b0201a807c687807264dddae7a02c7e6c51fe9353cb43cb46f0ea38ac36ec3a5958b45e96e7c00088d33f8c6f SHA512 09381b300afff26f8139eb36433b22fea0c909b6c68615b17821fb373afa168e1432eb93728a0189d89b04268c3e57fe237f7b52b1fa1f3aa7f92eadf411b98a
DIST backrefs-5.5.gh.tar.gz 5401839 BLAKE2B e8674de4b1f9a068bf7439e56fd14de8afed0635b0f6fe3c99c64b678890939186c7aa2d660bee73d51e01cc982186bddeaf2e4bea5754c1a234992d518f8004 SHA512 00074d30a96da6bd0aedcd3cec02f533a264514832d91ff466a50937fae28566fe95db7fbedc7ffd185300b9529adf7f89bd4366e09f2bd864fa4f0f13963475
diff --git a/dev-python/backrefs/backrefs-5.5.1.ebuild b/dev-python/backrefs/backrefs-5.5.1.ebuild
new file mode 100644
index 000000000000..c388a3ef35bc
--- /dev/null
+++ b/dev-python/backrefs/backrefs-5.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper around re or regex that adds additional back references"
+HOMEPAGE="
+ https://github.com/facelessuser/backrefs/
+ https://pypi.org/project/backrefs/
+"
+SRC_URI="
+ https://github.com/facelessuser/backrefs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest