summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 02:05:08 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 03:16:56 -0700
commitd6a421a790e3da39b8f450098f92f37be1b3f83b (patch)
treeaa842e4a52923ccf65ca1152440338961fa69c23 /dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
parentsci-calculators/units: stabilise 2.14-r1 for amd64/x86 (diff)
downloadgentoo-d6a421a790e3da39b8f450098f92f37be1b3f83b.tar.gz
gentoo-d6a421a790e3da39b8f450098f92f37be1b3f83b.tar.bz2
gentoo-d6a421a790e3da39b8f450098f92f37be1b3f83b.zip
dev-python/basho-erlastic: new package
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild')
-rw-r--r--dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild b/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
new file mode 100644
index 000000000000..1343d4db951a
--- /dev/null
+++ b/dev-python/basho-erlastic/basho-erlastic-2.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Erlang binary term codec and port interface."
+HOMEPAGE="https://github.com/basho/python-erlastic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests.py || die
+}