summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 22:15:18 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:32 -0500
commitedbcddddde19816ecee31672977398b482d8fcd6 (patch)
treec1ec0c7fab22b7ebad337d3f4900f76beeecd753 /dev-python/bcrypt
parentdev-python/stevedore: 1.30.1 bump (diff)
downloadgentoo-edbcddddde19816ecee31672977398b482d8fcd6.tar.gz
gentoo-edbcddddde19816ecee31672977398b482d8fcd6.tar.bz2
gentoo-edbcddddde19816ecee31672977398b482d8fcd6.zip
dev-python/bcrypt: 3.1.6 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/bcrypt')
-rw-r--r--dev-python/bcrypt/Manifest1
-rw-r--r--dev-python/bcrypt/bcrypt-3.1.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/bcrypt/Manifest b/dev-python/bcrypt/Manifest
index e7652dab2cae..0342bfeb175c 100644
--- a/dev-python/bcrypt/Manifest
+++ b/dev-python/bcrypt/Manifest
@@ -1,2 +1,3 @@
DIST bcrypt-3.1.3.tar.gz 40806 BLAKE2B 60b42bd4326ae1285911a79eff43f871366d6db8f1c2eb102f4f4cd3e91d29e58d30906b542d6f04ec0608dd5583550c0c9ddb795d8fd05cd1802396535ba59b SHA512 1fe80a156cd3707c27d4d3b6495caede3404acfdcd238d0461fdd83249601a0b0f2945e0f531dd4422f19e9cd47107245d8e40eb8b47b78e5c679e7e6b37a92c
DIST bcrypt-3.1.4.tar.gz 42575 BLAKE2B c4521ecfa55e5b857e35c9d9e402b8e911b2546bdb349a4e87f31e6af0a2686ebc9df4fc6268534c65d3bca8facfa2e8ccd549174f8f91a25002e94ba7fb9be4 SHA512 885dadec10aa9c5944a68e73ebc3ba409d41517850fad1bcb61321a8ce4072b95422472b9f7ca76508e9b0d24a86e19f3e415a0713f0a1921b9d3f796089ae71
+DIST bcrypt-3.1.6.tar.gz 42216 BLAKE2B 280e2d01d3d5195fe7d32426b9e9bb7b4544dd1c0027a9d1b4be287e21759efcb274cb3f943a913891fd63183f0525f7f301b6d76055a37240a7594240bbff33 SHA512 fcd4f3ec27ee27b4523c9f9b796e9c279895ad66d124fdabaee61b3fb27351b2e8721deb97e7bfc4f07ac4cfad6c2948d467cf21faba2af656ab0030c842244e
diff --git a/dev-python/bcrypt/bcrypt-3.1.6.ebuild b/dev-python/bcrypt/bcrypt-3.1.6.ebuild
new file mode 100644
index 000000000000..5c23585bad78
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-3.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.org/project/bcrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="test"
+
+COMMON_DEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/py-bcrypt"
+
+python_test() {
+ esetup.py test
+}