summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-17 15:52:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-17 16:44:20 +0100
commit48f648f8b978bb118e9d0eb9cb58d781d102a3b1 (patch)
treee9682337f529c1cf3ec941b4fe65ea35bf9c9b1b /dev-python/beartype
parentdev-python/translate-toolkit: Bump to 3.8.2 (diff)
downloadgentoo-48f648f8b978bb118e9d0eb9cb58d781d102a3b1.tar.gz
gentoo-48f648f8b978bb118e9d0eb9cb58d781d102a3b1.tar.bz2
gentoo-48f648f8b978bb118e9d0eb9cb58d781d102a3b1.zip
dev-python/beartype: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beartype')
-rw-r--r--dev-python/beartype/Manifest1
-rw-r--r--dev-python/beartype/beartype-0.12.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 0d25f2580d99..f590e489cc58 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1 +1,2 @@
DIST beartype-0.11.0.gh.tar.gz 806671 BLAKE2B 757764885fb99d82ecd2d7e205329a4f66898e0552e29216ca943ebc79661d0f43454dd43b0a7529cb148c0a50c9241eef56f7d5f1534290496d9811b3b9dac6 SHA512 23aff4208f6e41a8f3366c161576e6a6ff30f8d702926a52c266da4d169d683341ca6e728f5882ea2dbe91be23e64314b43343db4fab795d08a2983015398d9d
+DIST beartype-0.12.0.gh.tar.gz 874431 BLAKE2B 0ad2a6c852b32427f8f9c5a8915e580601b24551e956d458a64cda4127bffe91a94ff676e2284daed6671e2c94515a234fd74dcb3d8a78616665490d1a780910 SHA512 2724f080a0f423a8b79b080843db696ee607f2e27ef52d726928086b643ebb31abe4e3ae24cae12075e222a21291d301601606640ca281ff98272578d5bf752e
diff --git a/dev-python/beartype/beartype-0.12.0.ebuild b/dev-python/beartype/beartype-0.12.0.ebuild
new file mode 100644
index 000000000000..b5b5c8c7f555
--- /dev/null
+++ b/dev-python/beartype/beartype-0.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype
+"
+SRC_URI="
+ https://github.com/beartype/beartype/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+)