summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 12:54:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 12:59:36 +0200
commita57b744ff4aeaf9e06c089d7fbf82cd8eed602d5 (patch)
tree692b6cc12f3c4ff1a0a59a160255ee612a568a20 /dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
parentsys-apps/colorized-logs: Migrate to cmake.eclass (diff)
downloadgentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.gz
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.bz2
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.zip
Rename dev-python/{beautifulsoup → beautifulsoup4}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild')
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
new file mode 100644
index 000000000000..78187c60a289
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc/source