summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-18 04:34:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-18 04:43:10 +0100
commitd27385312f7f19ced8bc47a7896f0e3deacdb35f (patch)
treeabaeb09fdd0c54aad48898658360cdf8f7c4bb0e /dev-python/beautifulsoup4
parentdev-python/urwid: Bump to 2.4.3 (diff)
downloadgentoo-d27385312f7f19ced8bc47a7896f0e3deacdb35f.tar.gz
gentoo-d27385312f7f19ced8bc47a7896f0e3deacdb35f.tar.bz2
gentoo-d27385312f7f19ced8bc47a7896f0e3deacdb35f.zip
dev-python/beautifulsoup4: Bump to 4.12.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest1
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index a3c28f2582d7..6354fbd94949 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1 +1,2 @@
DIST beautifulsoup4-4.12.2.tar.gz 505113 BLAKE2B 94412a87dcffeb14655417eb61a784c8933aea79c81721ebf30114d55fd3e0f58850e0cfed354d3573d1bf18b556f3d83474b64a2a8d88f503c5125d5931321d SHA512 1dbb620f675bb319ef050ece0f343e80359bdc59cd8b8de19b1851aa5bca1081a7e953e3221ad97142198c17f67384c05b0406af24a123d71398f209fb89db97
+DIST beautifulsoup4-4.12.3.tar.gz 581181 BLAKE2B dac85b2d56ad1d2faf040def2141cb7a7ca68def7fc48fab18e11c23878795fcecfdd43058e70229e014e23e67f56a55160aa4ba08bab4b3d955bd10a07c8168 SHA512 b5b6cc9f64a97fa52b9a2ee1265aa215db476e705d3d79e49301de7e8d36c56c96924cb440eec0715f7ec75c5ddf4c1ade9d6cef7cdc9bf9e37125ac6eb50837
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
new file mode 100644
index 000000000000..784eac739f5f
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="
+ https://www.crummy.com/software/BeautifulSoup/bs4/
+ https://pypi.org/project/beautifulsoup4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/soupsieve-1.3[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source