summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-26 15:51:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-26 15:52:10 +0200
commit022047bf71f814e08f2f08a6c7bc92901a185a79 (patch)
tree802fd4060decce61e41797315ace594d0d77215f /dev-python/beautifulsoup
parentdev-lang/mercury-extras: support libressl in mopenssl Mercury package (diff)
downloadgentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.tar.gz
gentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.tar.bz2
gentoo-022047bf71f814e08f2f08a6c7bc92901a185a79.zip
dev-python/beautifulsoup: Bump to 4.9.1
Closes: https://bugs.gentoo.org/733912 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/Manifest1
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index c92891dad806..4e9620ac3f39 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1 +1,2 @@
DIST beautifulsoup4-4.8.2.tar.gz 298650 BLAKE2B 6826abf793efa63be89d844bc25bdb105413196bfab21c18f3816fd59a7a771459bf2c7ee209b75b0c88dfa14da8f4625c948889acfb48502e2260ccca229675 SHA512 aab90eb22614e9a2fb47792389a951b3ad7faf9791e15984a6c27a38be6f3d0ccbf3a9753d9afb5c70105097ac1a9c5f9e07206e12c6d4cb7a7f6d4e90ec18c2
+DIST beautifulsoup4-4.9.1.tar.gz 374759 BLAKE2B 43f5dc296bd0c4967036fcb70889f988c0dfc9d8713f8bbab423c9089e87960323392458b3abb9b2332acff286efbbb308a5c77058462c15f8dfe9056f0304c3 SHA512 a1fe9cbfe8616d2ff25cc836769ff02d51ed86b06ca9a37366867b145440b7f64b866346600ed74820f0407c8e70eaac3d58700766a99b5ff7433cb736a57b3c
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
new file mode 100644
index 000000000000..bea89dc44f97
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}