summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-26 15:36:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-26 15:36:00 +0100
commit0ee9f86f265527366f6d22ad16086cec1265f6a8 (patch)
tree1c7fa3c3095b115f4f1b2460c74fb3ec49b718e4 /dev-python/blaze
parentdev-python/bcolz: Remove old (diff)
downloadgentoo-0ee9f86f265527366f6d22ad16086cec1265f6a8.tar.gz
gentoo-0ee9f86f265527366f6d22ad16086cec1265f6a8.tar.bz2
gentoo-0ee9f86f265527366f6d22ad16086cec1265f6a8.zip
dev-python/blaze: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/blaze')
-rw-r--r--dev-python/blaze/Manifest1
-rw-r--r--dev-python/blaze/blaze-0.10.2.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/blaze/Manifest b/dev-python/blaze/Manifest
index a12536c02840..1f7634ec56c8 100644
--- a/dev-python/blaze/Manifest
+++ b/dev-python/blaze/Manifest
@@ -1,2 +1 @@
-DIST blaze-0.10.2.tar.gz 9681767 BLAKE2B 9972d0f9bb00ce462f20673e9e164d504bc1157730bcb36a42b53ed1523a73bde36a1858ba7df1f813c126291251c6170da8ac70aaaac8932206de5f3e063a10 SHA512 01b7c5563f928c336f13eb13c6397f1089bca7c1cf0824da672acdabf28b18356c52678c58b2fa7af303601c6013e9d6f4fe26359ee6ab9a01f8b735c7d24a56
DIST blaze-0.11.3.tar.gz 9691443 BLAKE2B 13734e3b2f63ad044991644a4c8243b449c5179a80efdaa5faf6ecf443434bec7a00953f0f17d73885b9e9fa506e72a9bc369380d2d7a561f5da064d8339e03f SHA512 030079e5d3f17355dac588154ffb7ba7993935dfd39bce141341b6e2b9a17f812982ce83776ac1e4224649a343b58615621347ba65e5aba2ca2e568d755f276f
diff --git a/dev-python/blaze/blaze-0.10.2.ebuild b/dev-python/blaze/blaze-0.10.2.ebuild
deleted file mode 100644
index 31109ca7fb71..000000000000
--- a/dev-python/blaze/blaze-0.10.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Next generation Python numpy"
-HOMEPAGE="https://blaze.pydata.org https://blaze.readthedocs.io/en/latest/"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-# Currently doc build fails, reason now, attempt to import mystery modules in datashape
-# Leaving doc build content in case this is fixed
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-# pyspark appears an optional dep not in portage. pyskit appears to be dropped
-# some packages including pyparsing appear required despite their absence from requirements.txt
-
-RDEPEND="
- dev-python/datashape[${PYTHON_USEDEP}]
- >=dev-python/dynd-python-0.6.5[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- dev-python/cytoolz[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.15.0[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/unicodecsv[${PYTHON_USEDEP}]
- >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- dev-python/flask-cors[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pymongo-2.8[${PYTHON_USEDEP}]
- dev-python/xlrd[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/into[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numba[${PYTHON_USEDEP}]
- dev-python/bcolz[${PYTHON_USEDEP}]
- >=dev-python/odo-0.4[${PYTHON_USEDEP}]"
-DEPEND="
- >=dev-python/cython-0.18[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/dask[${PYTHON_USEDEP}] )
- "
-# It was found on testing that dev-python/chardet is required for tests
-# despite not being inlcuded in requirements.txt
-# The doc build now fails due to dep bokeh failing to emerge. Deleted.
-
-python_test() {
- # https://github.com/ContinuumIO/blaze/issues/1117
- # skip test requiring a server daemon
- # Tally of known failure reduced to one under py2.7 (test_highly_nested_repr)
- # and 2 under py3. The failure of test_query_with_strings persists
- # under python3 and appears to be unaddressed upstream.
- # Changes in the suite in this version require PYTHONPATH set to ${S}
- # to avoid spurious errors resulting from the change of path set by the eclass.
-
- einfo "The test suite has 4 additional failures with package numba installed"
- einfo "Upstream have been informed via /blaze/issues/1117 @ github.com/"
- einfo "For optimum results, uninstall numba, but it counters protocol to exclude"
- einfo "dev-python/numba from dependencies in the ebuild"
-
- PYTHONPATH="${S}" py.test --ignore blaze/compute/tests/test_mongo_compute.py blaze \
- || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( blaze/examples/. )
-
- distutils-r1_python_install_all
-}