summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:36:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 08:04:16 +0100
commit713a5d6446b6d906d78ca057183f99451f005bed (patch)
treefec7f6dbfd9a842419fcda3f6560f9b171dfc4d8 /dev-python/bleach
parentdev-python/sphinxcontrib-applehelp: Bump to 1.0.4 (diff)
downloadgentoo-713a5d6446b6d906d78ca057183f99451f005bed.tar.gz
gentoo-713a5d6446b6d906d78ca057183f99451f005bed.tar.bz2
gentoo-713a5d6446b6d906d78ca057183f99451f005bed.zip
dev-python/bleach: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-6.0.0.ebuild46
-rw-r--r--dev-python/bleach/files/bleach-6.0.0-py39.patch48
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index cd9a7af8b9dc..77a6e9c7d92d 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-5.0.1.tar.gz 199642 BLAKE2B 8d06dd38e89b91bf48f3481b5337b8d9700d8cc88faf3a260898b2b8f15ecf5c5160f96bff2c5ce02f361b773b0ce9a51322d9836dcc99b7878921846e8da182 SHA512 6c8e80eaf6db6f0e6d9066f3443192f44c489e079945b6d11b11e7eb270ea865011019e05d43c7896262dc11ca168e697630d9da8dca9f5bb48f0e2161fda6c8
+DIST bleach-6.0.0.tar.gz 201298 BLAKE2B e4af5da351fdb63bc75b935f70f40434bd81c49cde4f584901397e5fd4ac4507d2e29eb283ff28a764018dbd795021e2edf1f43385ff8a2d7d8affd358fc0e31 SHA512 95900e4347c1f7d0aa5b2e8fbf43fac6410dd6bbbac988fb3f407a964d0aa1dc51fe3cf17459e6ce762a02b45bb3d20b539ca05727278d120aee9500cf0d208a
diff --git a/dev-python/bleach/bleach-6.0.0.ebuild b/dev-python/bleach/bleach-6.0.0.ebuild
new file mode 100644
index 000000000000..350261336111
--- /dev/null
+++ b/dev-python/bleach/bleach-6.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="
+ https://github.com/mozilla/bleach/
+ https://pypi.org/project/bleach/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/bleach-6.0.0-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.parse:urllib.parse:' \
+ bleach/parse_shim.py || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py \
+ bleach/sanitizer.py \
+ tests/test_clean.py || die
+ # indirect html5lib deps
+ sed -i -e '/six/d' -e '/webencodings/d' setup.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/bleach/files/bleach-6.0.0-py39.patch b/dev-python/bleach/files/bleach-6.0.0-py39.patch
new file mode 100644
index 000000000000..02ecb614c8b9
--- /dev/null
+++ b/dev-python/bleach/files/bleach-6.0.0-py39.patch
@@ -0,0 +1,48 @@
+From d6d734f6fbeee2c091212d42e3ea730a1230aad5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 24 Jan 2023 07:35:45 +0100
+Subject: [PATCH] Remove tests broken by py3.9
+
+---
+ tests/test_clean.py | 15 ---------------
+ 1 file changed, 15 deletions(-)
+
+diff --git a/tests/test_clean.py b/tests/test_clean.py
+index 73946a1..f798a15 100644
+--- a/tests/test_clean.py
++++ b/tests/test_clean.py
+@@ -551,31 +551,16 @@ def test_attributes_list():
+ {"protocols": {"http"}},
+ '<a href="example.com">valid</a>',
+ ),
+- (
+- '<a href="example.com:8000">valid</a>',
+- {"protocols": {"http"}},
+- '<a href="example.com:8000">valid</a>',
+- ),
+ (
+ '<a href="localhost">valid</a>',
+ {"protocols": {"http"}},
+ '<a href="localhost">valid</a>',
+ ),
+- (
+- '<a href="localhost:8000">valid</a>',
+- {"protocols": {"http"}},
+- '<a href="localhost:8000">valid</a>',
+- ),
+ (
+ '<a href="192.168.100.100">valid</a>',
+ {"protocols": {"http"}},
+ '<a href="192.168.100.100">valid</a>',
+ ),
+- (
+- '<a href="192.168.100.100:8000">valid</a>',
+- {"protocols": {"http"}},
+- '<a href="192.168.100.100:8000">valid</a>',
+- ),
+ pytest.param(
+ *(
+ '<a href="192.168.100.100:8000/foo#bar">valid</a>',
+--
+2.39.1
+