summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 23:22:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 23:22:08 +0200
commit3804e794a1e6fe574c302fb0cbcc0b8aabd7fc10 (patch)
treeb759179b800e044c6b5d5581d1c6851ff205b84c /dev-python/boto3
parentdev-python/botocore: Bump to 1.21.57 (diff)
downloadgentoo-3804e794a1e6fe574c302fb0cbcc0b8aabd7fc10.tar.gz
gentoo-3804e794a1e6fe574c302fb0cbcc0b8aabd7fc10.tar.bz2
gentoo-3804e794a1e6fe574c302fb0cbcc0b8aabd7fc10.zip
dev-python/boto3: Bump to 1.18.57
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.57.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b93e1798d704..65bde51ba5e8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.18.53.tar.gz 422176 BLAKE2B a07155f6be71c049479c1d2e47767bb2c686307
DIST boto3-1.18.54.tar.gz 422231 BLAKE2B a010a19a801a939421fab0b8b28ca36bfaceb30380d4e7ace262294acebbc12209cb05ee207a2c8ee536735aadf01c4d15f1c92ab86543970cd967d8a5300b3b SHA512 cb4ee30ee2f7c2270b0f0689707d129fbce94a2e740e4d836c41fb1bb641345ac73aefe60a6e1072f3d8ad87709b3411539a7fda8542c98cbb7bb4ae1872ead5
DIST boto3-1.18.55.tar.gz 422930 BLAKE2B 2e30f585f2a99d30b9683893c706a9d00bcabc15bba7f033753cf8c0463c40227a5c668f29deff78da0cca02321e79a99329fa5acb8a4e6430970c08f1fe851a SHA512 1b885d423f17edcd441c48a3a456c70f823fd65b94ac89011d1dcfee1ba1d67fbe7e9470869d73733876abdaa4d8e13593ceaffd446ff46e4dc2dbd85cb2bc30
DIST boto3-1.18.56.tar.gz 423262 BLAKE2B 97caee83b3bd074157096383d069427f1a2fae7917927983d5e9f3c1f11cf5d710050a505bdfa047259434b9b8f358f276de54a9e879b31c0eafb3c14f5c172a SHA512 cda79fc07e1f4c37b3aa0644bd1e81e157de19b1b47f4cebd5d7a66e5ca9653649ba9bf84c7d88dce383b592d673b0ee85fa823247517aa24f869af13755ed2d
+DIST boto3-1.18.57.tar.gz 423704 BLAKE2B 8b778a6e5549ed81ae411521e3d1e4792a18a539a3f7896022739ca25a9ee1f266b555f4baee507ac71c5129c6a8e919e6d95255f5c0dd64136d89d6fbe5605a SHA512 cad772acd9c93e61fd3f77c935986e0d50235591c63bcb27bc925292012a66c7d0a4a62e6c5129b8f26978eb9e5802eb80533e24566d8b369951c6c5ea42e28c
diff --git a/dev-python/boto3/boto3-1.18.57.ebuild b/dev-python/boto3/boto3-1.18.57.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.57.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}