summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 08:30:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 09:21:03 +0200
commit98229362a2b58fac43f6c3a4b9c5f722eb00e408 (patch)
tree986e926b493749243b4518e61d6677ee95c6c323 /dev-python/boto3
parentdev-python/botocore: Bump to 1.21.56 (diff)
downloadgentoo-98229362a2b58fac43f6c3a4b9c5f722eb00e408.tar.gz
gentoo-98229362a2b58fac43f6c3a4b9c5f722eb00e408.tar.bz2
gentoo-98229362a2b58fac43f6c3a4b9c5f722eb00e408.zip
dev-python/boto3: Bump to 1.18.56
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.56.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 736addbc15f1..b93e1798d704 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.18.47.tar.gz 420701 BLAKE2B e58f528d876a29cd992a414e84a807a4fefdeb1
DIST boto3-1.18.53.tar.gz 422176 BLAKE2B a07155f6be71c049479c1d2e47767bb2c6863075ea0085ca5cc4609e28aa8b0af0e2136754c0ed6fd05dfecab079f76d636e19e1b8af4b68220768cea6125e93 SHA512 ae774e3db52a90a0850b4bd90be105d4ab59b6478ed16e30e2cc5afec0664e2b13438ab7a460e570c680d49be240855b7c9ae30a373c83d50dda5da6b84d01b7
DIST boto3-1.18.54.tar.gz 422231 BLAKE2B a010a19a801a939421fab0b8b28ca36bfaceb30380d4e7ace262294acebbc12209cb05ee207a2c8ee536735aadf01c4d15f1c92ab86543970cd967d8a5300b3b SHA512 cb4ee30ee2f7c2270b0f0689707d129fbce94a2e740e4d836c41fb1bb641345ac73aefe60a6e1072f3d8ad87709b3411539a7fda8542c98cbb7bb4ae1872ead5
DIST boto3-1.18.55.tar.gz 422930 BLAKE2B 2e30f585f2a99d30b9683893c706a9d00bcabc15bba7f033753cf8c0463c40227a5c668f29deff78da0cca02321e79a99329fa5acb8a4e6430970c08f1fe851a SHA512 1b885d423f17edcd441c48a3a456c70f823fd65b94ac89011d1dcfee1ba1d67fbe7e9470869d73733876abdaa4d8e13593ceaffd446ff46e4dc2dbd85cb2bc30
+DIST boto3-1.18.56.tar.gz 423262 BLAKE2B 97caee83b3bd074157096383d069427f1a2fae7917927983d5e9f3c1f11cf5d710050a505bdfa047259434b9b8f358f276de54a9e879b31c0eafb3c14f5c172a SHA512 cda79fc07e1f4c37b3aa0644bd1e81e157de19b1b47f4cebd5d7a66e5ca9653649ba9bf84c7d88dce383b592d673b0ee85fa823247517aa24f869af13755ed2d
diff --git a/dev-python/boto3/boto3-1.18.56.ebuild b/dev-python/boto3/boto3-1.18.56.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.56.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}