summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 09:44:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:20:47 +0100
commitc4284c2e49051564a5b288587ba3c7fcf6be76d0 (patch)
tree2a8a7020bc9ea4aa53dd0789f06d9ac1bf9ffa7a /dev-python/boto3
parentdev-python/botocore: Bump to 1.23.1 (diff)
downloadgentoo-c4284c2e49051564a5b288587ba3c7fcf6be76d0.tar.gz
gentoo-c4284c2e49051564a5b288587ba3c7fcf6be76d0.tar.bz2
gentoo-c4284c2e49051564a5b288587ba3c7fcf6be76d0.zip
dev-python/boto3: Bump to 1.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1337c23a4da5..e2443ebdc4fd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.18.60.tar.gz 428327 BLAKE2B d559c7512c7ab1160dfec4616741002ce82357d
DIST boto3-1.18.65.tar.gz 429858 BLAKE2B fbc80e0d8d10f6d02fcf9b86c6b4be03a9c908318c507a7cde1eef0c36d8fe3a5d3be0f8c6178edfdd8bc82adf112f297a5f127cd2b442ce10fe4d37b3a21fa4 SHA512 631d8f618fb6d55b338b563e72e1ccc751b8937bb2660d033b885951ea5ec3ac6902f8c7b9918664d764be84fdef5af4e7a87d444cbc154ebf5ae06908f90714
DIST boto3-1.19.12.tar.gz 436654 BLAKE2B f92e756bc9f98105e3126e41cf0d6fab948bbd79f088ee4e0f0f5f319d4a6e542c0702b487404b316f794b304c43f9c26da026257476341971a7ce241538f506 SHA512 e6b20730f35bb422a2f74e978adc0bac77aa18b4e80eab5175dc117cf2762a7d8e53d390c50df24dada6f1d071d78309c69598ffb3f8d93fd45a3d1f772a866f
DIST boto3-1.19.5.tar.gz 433567 BLAKE2B 52c12a4dd18d6f02326f8002b345cc5df224455fc862daa700326ae1df258979211d2753f01e1a106f237de393e483dc8926bb4ef0e08bafa575f20811dccd55 SHA512 fad05102f0c3e7e30a3342009f6b3ae28f52758f17a0c22b4da9a03dd10d7f9149ea2ec0119f55ec7280824bd8173653271821e82fcd54ef9fb9161b2d62df70
+DIST boto3-1.20.1.tar.gz 437338 BLAKE2B b2d952263919404518ada651777fd8cbe501b46fe060c4e4c657e2a01801e8f4b0285864cef880cc7ffeb83a84709f1bc91de26d70378a7ab01e681cc8098857 SHA512 0536a90cefbe739941d1eb5e2cb667de144648a8ba4329b49475fc15855c495fdbb0bf73d0c5de57adfb58f86e01e19ff4ce876eabf185a1f5a93499dafa6d49
diff --git a/dev-python/boto3/boto3-1.20.1.ebuild b/dev-python/boto3/boto3-1.20.1.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}