summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 17:24:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 17:27:50 +0100
commit11d1abde5f2eaca9028821d4211a89f1b2f69253 (patch)
tree98991bc04859ff44b9ad21b49dcf9342d8890fb5 /dev-python/boto
parentdev-python/fasteners: Remove py2 (diff)
downloadgentoo-11d1abde5f2eaca9028821d4211a89f1b2f69253.tar.gz
gentoo-11d1abde5f2eaca9028821d4211a89f1b2f69253.tar.bz2
gentoo-11d1abde5f2eaca9028821d4211a89f1b2f69253.zip
dev-python/boto: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/boto-2.49.0.ebuild33
1 files changed, 3 insertions, 30 deletions
diff --git a/dev-python/boto/boto-2.49.0.ebuild b/dev-python/boto/boto-2.49.0.ebuild
index 2a6f4b57820e..ed057dd745cf 100644
--- a/dev-python/boto/boto-2.49.0.ebuild
+++ b/dev-python/boto/boto-2.49.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -13,42 +13,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
# requires Amazon Web Services keys to pass some tests
RESTRICT="test"
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
python_test() {
"${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
}
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Appease the doc build and supply a file for _static
- # the usual emake -C docs doesn't work under this authorship
- cd docs && mkdir source/_static || die
- emake html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}